Closed Bug 1163636 Opened 6 years ago Closed 6 years ago

High-DPI Downloads button gets Low-DPI once pressed

Categories

(Firefox :: Toolbars and Customization, defect)

40 Branch
x86_64
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1153529
Tracking Status
firefox38 --- unaffected
firefox38.0.5 --- unaffected
firefox39 --- unaffected
firefox40 --- fixed

People

(Reporter: mtanalin, Unassigned)

References

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:40.0) Gecko/20100101 Firefox/40.0
Build ID: 20150510030207

Steps to reproduce:

Firefox 40 finally adds some High-DPI toolbar icons (e.g. used at 200% system-level scale) for main GUI (Australis menu is still entirely Low-DPI though).

But the Downloads button is buggy:

by default, the Downloads button is High-DPI, but once pressed/clicked, it immediately gets blurry Low-DPI as in previous Firefox versions.

Tested with the latest nightly build 20150510030207.

High-DPI icons themselves have been added in the build 20150410030204.


Actual results:

High-DPI Downloads button gets Low-DPI once pressed/clicked.


Expected results:

High-DPI Downloads button should be permanently High-DPI regardless of whether is has been pressed/clicked.
Component: Untriaged → Toolbars and Customization
Same with the new build 20150511030203.
OS: Unspecified → Windows 7
Hardware: Unspecified → x86_64
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 878288
This bug should not have been duped. We should get this fixed in Firefox 40 so it rides along with bug 1147702.
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: DUPLICATE → ---
Status: REOPENED → NEW
[Tracking Requested - why for this release]:
Firefox 40 introduced hires icons for Windows on the toolbar, it looks like this one was missed.
(In reply to comment #5)
> Firefox 40 introduced hires icons for Windows on the toolbar, it looks like
> this one was missed.

To be clear: the high-DPI icon for Downloads button is NOT missing in Fx40+, the button IS high-DPI by default, but becomes low-DPI after it has been pressed (after browser restart, the button is high-DPI again until it's pressed).

Probably a purely stylesheet-level issue (like if the button was a link, and the `:visited` link had the low-DPI icon assigned).
Apparently the bug reason is that once Downloads button (`#downloads-button`) is pressed, it gets invisible (`display: none`) due to `indicator` attribute (see "browser\chrome\browser\content\browser\browser.css" in Firefox folder or "chrome://browser/content/browser.css" as URL):

    #downloads-button[indicator]:not([cui-areatype="menu-panel"]) > image.toolbarbutton-icon,
    #downloads-button[indicator][cui-areatype="menu-panel"] > #downloads-indicator-anchor {
      display: none;
    }

and instead of it, the `#downloads-indicator-anchor` element is dynamically inserted. This new element contains the `#downloads-indicator-icon` element, and this element has only low-DPI icon ("chrome://browser/skin/Toolbar.png", not "chrome://browser/skin/Toolbar@2x.png") assigned via styles ("browser\chrome\browser\skin\classic\browser\browser.css"):

    #downloads-indicator-icon {
      background: -moz-image-rect(url("chrome://browser/skin/Toolbar.png"),
                                  0, 198, 18, 180) center no-repeat;
      min-width: 18px;
      min-height: 18px;
    }
    
    toolbar[brighttext] #downloads-button:not([attention]) > #downloads-indicator-anchor > #downloads-indicator-icon {
      background: -moz-image-rect(url("chrome://browser/skin/Toolbar-inverted.png"),
                                  0, 198, 18, 180) center no-repeat;
    }
    
    #downloads-button[attention] > #downloads-indicator-anchor > #downloads-indicator-icon {
      background-image: -moz-image-rect(url("chrome://browser/skin/Toolbar.png"), 18, 198, 36, 180);
    }
    
    toolbar[brighttext] #downloads-button[attention] > #downloads-indicator-anchor > #downloads-indicator-icon {
      background-image: -moz-image-rect(url("chrome://browser/skin/Toolbar-inverted.png"), 18, 198, 36, 180);
    }
Thanks for the investigation. Would you like to submit a patch to fix this?
Flags: needinfo?(mtanalin)
Unfortunately I have no experience of creating patches for Firefox (nor is my XUL knowledge deep enough), but hopefully based on the info I've provided, it will be trivial for a Mozilla developer (probably that who has already added high-DPI icons in their current state) to create the patch. Thanks.
Flags: needinfo?(mtanalin)
See Also: → 1153529
Blocks: 1147702
Status: NEW → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → DUPLICATE
See Also: 1153529
Duplicate of bug: 1153529
You need to log in before you can comment on or make changes to this bug.