Closed Bug 116366 Opened 18 years ago Closed 18 years ago

this.parentNode.parentNode.parentNode.addToMissedIconCache is not a function

Categories

(SeaMonkey :: UI Design, defect)

x86
Windows NT
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
mozilla0.9.8

People

(Reporter: boullet.marc, Assigned: hewitt)

Details

buildId 2001121909 NT4

Noticed this error in the javascript console since
2001121703.
-->hyatt since it seems to be related to favicon cache 
Assignee: pchen → hyatt
QA Contact: sairuh → claudius
win32 build 2001122103, win98se (classic)

The above message shows up in the js console when a link is left-clicked, or
right-clicked and selecting Open in New Window.  Seemingly related message after
right-click on a link and selecting Open in New Tab:

Error: this.mMissedIconCache has no properties
Source File:
chrome://global/content/bindings/tabbrowser.xml#tabbrowser.addToMissedIconCache()
Line: 2
A side effect seems to be that the "loading" icon doesn't display in tabs.
Also seems to affect just Classic.  In Modern, the "loading" icon does display,
and neither message displays. 
Status: UNCONFIRMED → NEW
Ever confirmed: true
Caused by hewitt restructuring tabbrowser (and probably the url bar too).  
--> hewitt
Assignee: hyatt → hewitt
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla0.9.8
Warning: reference to undefined property
this.parentNode.parentNode.parentNode.addToMissedIconCache

This happens many many times because of due to a couple of bugs involving error
messages and event handlers.
fixed
Status: ASSIGNED → RESOLVED
Closed: 18 years ago
Resolution: --- → FIXED
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.