Closed Bug 1163681 Opened 5 years ago Closed 5 years ago

Boot animation should handle fence correctly

Categories

(Core Graveyard :: Widget: Gonk, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:2.2+, firefox39 wontfix, firefox40 wontfix, firefox41 fixed, b2g-v2.2 fixed, b2g-master fixed)

RESOLVED FIXED
mozilla41
blocking-b2g 2.2+
Tracking Status
firefox39 --- wontfix
firefox40 --- wontfix
firefox41 --- fixed
b2g-v2.2 --- fixed
b2g-master --- fixed

People

(Reporter: sotaro, Assigned: sotaro)

References

Details

(Whiteboard: [caf priority: p2][CR 838321])

Attachments

(2 files, 3 obsolete files)

Bootanimation code path does not handle fence correctly.
blocking-b2g: --- → 2.2?
Assignee: nobody → sotaro.ikeda.g
Attached patch patch - Fix fence handling (obsolete) — Splinter Review
Attachment #8604233 - Flags: review?(mwu)
Blocks: 1155498
Blocks: 1032180
Comment on attachment 8604233 [details] [diff] [review]
patch - Fix fence handling

I am going to update a patch.
Attachment #8604233 - Flags: review?(mwu)
Attachment #8604233 - Flags: review?(mwu)
(In reply to Sotaro Ikeda [:sotaro] from comment #3)
> Comment on attachment 8604233 [details] [diff] [review]
> patch - Fix fence handling
> 
> I am going to update a patch.

Update seems not necessary.
Attached patch patch - Fix fence handling (obsolete) — Splinter Review
Add "ANDROID_VERSION == 17" handling.
Attachment #8604233 - Attachment is obsolete: true
Attachment #8604233 - Flags: review?(mwu)
Attachment #8604640 - Flags: review?(mwu)
Attachment #8604235 - Attachment is obsolete: true
Fix indent.
Attachment #8604640 - Attachment is obsolete: true
Attachment #8604640 - Flags: review?(mwu)
Attachment #8604643 - Flags: review?(mwu)
Blocks: 1144012
Comment on attachment 8604641 [details] [diff] [review]
patch for b2g v2.2 - Fix fence handling

This patch fixes the fence sync error from bug 1162715 on my L prototype device. Thanks Sotaro!
Attachment #8604641 - Flags: feedback+
Thanks for the feedback!
Comment on attachment 8604643 [details] [diff] [review]
patch - Fix fence handling

Review of attachment 8604643 [details] [diff] [review]:
-----------------------------------------------------------------

Ah, I see. The old code was completely wrong. Thanks
Attachment #8604643 - Flags: review?(mwu) → review+
Keywords: verifyme
Hi Sotaro,
Could you provide more information about the impact of the bug for triaging? Thanks!
Flags: needinfo?(sotaro.ikeda.g)
Without the fix, Bug 1162715 could happen. It could freeze OpenGL rendering several seconds and bootanimation rendering flickering could happen.
Flags: needinfo?(sotaro.ikeda.g)
Whiteboard: [CR 838321]
Whiteboard: [CR 838321] → [caf priority: p2][CR 838321]
https://hg.mozilla.org/mozilla-central/rev/710a15bf959f
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla41
Hi Sotaro, just a reminder to please request approval for b2g37 when you are ready to uplift for 2.2.
Flags: needinfo?(sotaro.ikeda.g)
blocking-b2g: 2.2? → 2.2+
Comment on attachment 8604641 [details] [diff] [review]
patch for b2g v2.2 - Fix fence handling

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Bug 1032180
User impact if declined: freezing OpenGL rendering several seconds and bootanimation rendering flickering could happen.
Testing completed: locally and codeauroa did test.
Risk to taking this patch (and alternatives if risky): low.
String or UUID changes made by this patch: none.
Flags: needinfo?(sotaro.ikeda.g)
Attachment #8604641 - Flags: approval-mozilla-b2g37?
Attachment #8604641 - Flags: approval-mozilla-b2g37? → approval-mozilla-b2g37+
No longer blocks: 1162715
Duplicate of this bug: 1162715
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.