[l12y][Search] Search suggestion dialog is not translated

RESOLVED INVALID

Status

Firefox OS
Gaia::Search
RESOLVED INVALID
3 years ago
3 years ago

People

(Reporter: YeojinC, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(b2g-v2.2 unaffected, b2g-master affected)

Details

(Whiteboard: [3.0-Daily-Testing][systemsfe])

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Description:
On Flame Master, the strings on the search suggestion dialog is not translated. It seems to be a recent regression, as the strings are correctly translated on BuildID: 20150507071613.

Pre-requisite: Have an internet connection.

Repro Steps:
1) Update a Flame to 20150511010202.
2) Set the device language in French.
3) Tap the rocketbar, and type in a few words.
4) Observe the dialog "Search suggestions are enabled. The characters you type when....."


Actual:
The strings in the dialog is in English.

Expected:
The strings in the dialog is in French.

Environmental Variables:
Device: Flame 3.0 (KK, 319mb, full flash)
Build ID: 20150511010202
Gaia: 6089234ace8b294a8feef064387604bae16254e3
Gecko: d8420a541d1c
Gonk: 040bb1e9ac8a5b6dd756fdd696aa37a8868b5c67
Version: 40.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

Repro frequency: 7/7
See attached: screenshot, logcat
(Reporter)

Comment 1

3 years ago
This issue does NOT reproduce on Flame 2.2.

Result: The search suggestion dialog is localized properly.

Environmental Variables:
Device: Flame 2.2 (KK, 319mb, full flash)
Environmental Variables:
Device: Flame 2.2
Build ID: 20150511002500
Gaia: 528ef60e7cda09ad43478065f5d33bda398fbeb7
Gecko: 8d04cc085cf5
Gonk: ab265fb203390c70b8f2a054f38cf4b2f2dad70a
Version: 37.0 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

==========================
This issue might have been caused by the fix for bug 1162274.
No longer blocks: 1142313, 1142526
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.2: --- → unaffected
status-b2g-master: --- → affected
No longer depends on: 1162274
Flags: needinfo?(ktucker)
(Reporter)

Comment 2

3 years ago
Created attachment 8604344 [details]
logcat_20150511_1440.txt
(Reporter)

Comment 3

3 years ago
Created attachment 8604346 [details]
French_SearchSuggestion.png
It's likely that we just don't have updated strings yet because of the key change?
Adding delphine to follow up here.
Flags: needinfo?(lebedel.delphine)
(In reply to Kevin Grandon :kgrandon from comment #4)
> It's likely that we just don't have updated strings yet because of the key
> change?

Yup, this looks like fallout from bug 1162274, which is normal in the l10n world.  I'm not convinced this is the right time to test master's localizations.
Closing this for now based on comment 6. A good way to test if this is the case is to use pseudo locales to see if the content translates.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(lebedel.delphine)
Resolution: --- → INVALID
Agreed with comment 6: testing only using pseudolocales and Italian should be ok on master. French used to be always caught up as well, which probably lead to the confusion in filing this bug
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.