Various serviceworker web-platform tests are going to permafail when Gecko 40 merges to Aurora due to "navigator.serviceWorker is undefined"

VERIFIED FIXED in Firefox 40

Status

()

defect
--
critical
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: RyanVM, Assigned: Ehsan)

Tracking

Trunk
mozilla41
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox40 verified, firefox41 verified)

Details

Attachments

(1 attachment)

+++ This bug was initially created as a clone of Bug #1161039 +++

Showed up with today's uplift today. Will be mass-disabling shortly.

https://treeherder.mozilla.org/logviewer.html#?job_id=821151&repo=mozilla-aurora

TEST-UNEXPECTED-FAIL | /service-workers/cache-storage/serviceworker/cache-add.https.html | Cache.add and Cache.addAll - navigator.serviceWorker is undefined

etc...
I thought service worker was pref'd on for non-release builds... but it appears just Nightly.

Ehsan, is this intentional?  Why?
Flags: needinfo?(ehsan)
Hmm, bug 1154900 also says "Nightly", so I guess that's what I had in mind.  We should probably pref on for non-release builds.  Filed bug 1164487.

But this bug would hit us on Beta even if we did that, so it should be fixed irrespective of the above.  I'll take it.
Assignee: nobody → ehsan
Component: DOM: Workers → DOM: Service Workers
Flags: needinfo?(ehsan)
For beta it will also need dom.caches.enabled set since thats also just non-release builds.
Attachment #8605362 - Flags: review?(james) → review+
https://hg.mozilla.org/mozilla-central/rev/67708ff58acc
https://hg.mozilla.org/mozilla-central/rev/436f73341387
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla41
Duplicate of this bug: 1161039
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.