blaming some files takes minutes on hg.mozilla.org, few seconds locally (blame)

RESOLVED FIXED

Status

Developer Services
Mercurial: hg.mozilla.org
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: aryx, Unassigned)

Tracking

Details

https://hg.mozilla.org/releases/mozilla-aurora/annotate/cc162b5c443c/mobile/android/base/locales/en-US/android_strings.dtd takes _very_ long to load (more than a minute). Blaming the file locally is fast (but I use MozillaBuild 1.11.0 with Mercurial 3.2.3).

Comment 1

3 years ago
This is fixed in Mercurial 3.4. But I'm not sure why our hgweb machines are slow - I thought we cherry picked and deployed all the patches related to annotate performance regressions.

Comment 2

3 years ago
https://hg.mozilla.org/releases/mozilla-aurora/annotate/cc162b5c443c/mobile/android/base/locales/en-US/android_strings.dtd now loads in ~3s (because we just deployed Mercurial 3.4.1 to hg.mozilla.org).
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.