[Dialer][Dial Pad] The asterisk key on the keypad does not have a blue comma (,) symbol to indicate long press functionality.

VERIFIED FIXED

Status

Firefox OS
Gaia::Dialer
VERIFIED FIXED
3 years ago
2 years ago

People

(Reporter: Marty, Assigned: drs)

Tracking

({polish})

unspecified
ARM
Gonk (Firefox OS)
polish

Firefox Tracking Flags

(feature-b2g:2.5+, b2g-v2.2 affected, b2g-master verified)

Details

(Whiteboard: [3.0-Daily-Testing], URL)

Attachments

(6 attachments)

(Reporter)

Description

3 years ago
Created attachment 8604349 [details]
logcat-dialer-comma.txt

Description:
In the dialer, if the user long-presses on the asterisk (*) key of the dial pad, a comma (,) will be entered into the dial field.  This is similar functionality to long-pressing the '0' key to add the '+' symbol, or long pressing the '1' key to dial voicemail.  Both '1' and '0' have blue symbols to indicate their long-press functionality, while the asterisk key does not have a blue symbol.

Repro Steps:
1) Update a Flame to 20150511010202
2) Open the Dialer app
3) Note the Asterisk (*) key.
4) Enter several numbers, then long press the Asterisk (*) key.

Actual:
The asterisk key does not display that long pressing it will enter a comma into the dial field.

Expected:
The asterisk key includes a blue comma (,) symbol indicating long-press functionality.

Environmental Variables:
Device: Flame 3.0 (319MB)(Full Flash)
Build ID: 20150511010202
Gaia: 6089234ace8b294a8feef064387604bae16254e3
Gecko: d8420a541d1c
Gonk: 040bb1e9ac8a5b6dd756fdd696aa37a8868b5c67
Version: 40.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

Repro frequency: 10/10
See attached: Video (URL), Logcat.
(Reporter)

Comment 1

3 years ago
Created attachment 8604350 [details]
Dialer-Comma-Screenshot.png
(Reporter)

Comment 2

3 years ago
This issue DOES occur on Flame 2.2 builds.
The asterisk key does not display that long pressing it will enter a comma into the dial field.

Environmental Variables:
Device: Flame 2.2 (319MB)(Full Flash)
Build ID: 20150511002500
Gaia: 528ef60e7cda09ad43478065f5d33bda398fbeb7
Gecko: 8d04cc085cf5
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
That's also inconsistent with the digits keyboard where the comma is located on the 6. Which key should we choose in this case, Carrie?
Flags: needinfo?(cawang)
I think the reason that we didn't add the symbol there is for the symmetry from visual perspective. I'd suggest adding the symbol "," to indicate users, but I'd like to know if this is a common use case? Thanks!
Flags: needinfo?(cawang)
Created attachment 8605136 [details]
Comma keypad in Contacts

(In reply to Carrie Wang [:carrie] from comment #4)
> I'd suggest adding the symbol "," to indicate users
To which key? We already display how to put a comma in the contact apps. See attached screenshot.

> but I'd like to know if this is a common use case? Thanks!
Telefónica wanted the ability to call contacts behind switchboards in 2.2  (see bug 911055 and bug 1131938). Beatriz might be able to answer to that question.
Flags: needinfo?(cawang)
Flags: needinfo?(beatriz.rodriguezgomez)
(In reply to Carrie Wang [:carrie] from comment #4)
> I think the reason that we didn't add the symbol there is for the symmetry
> from visual perspective. I'd suggest adding the symbol "," to indicate
> users, but I'd like to know if this is a common use case? Thanks!
I can only explain that this is covered in our testing process in all latam countries but I do not have info about how often customers use it.
The other info we had that this feature is requested by customers come from SUMO at: https://bugzilla.mozilla.org/show_bug.cgi?id=911055#c2
Hope it helps! Sorry!
Flags: needinfo?(beatriz.rodriguezgomez)
Hi Johan, 

The Contacts APP is using a different keypad. We are talking about the dialer pad in Dialer. So if we are going to indicate user to long-press for "comma", we may need to add it the the asterisk key (in Dialer). Thanks!
Flags: needinfo?(cawang)
Got it. Thanks for the confirmation.

[Blocking Requested - why for this release]: That's a feature introduced in 2.2, but it's too late to block 2.2 on it. I'd suggest we have it on 3.0.
blocking-b2g: --- → 3.0?
Keywords: polish
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga)
Comms triage: Missing element on the UI.
blocking-b2g: 3.0? → 3.0+
(Assignee)

Updated

2 years ago
Assignee: nobody → drs
Removing blocking b2g 2.5+ flag. Changed it to feature 2.5+ flag
blocking-b2g: 2.5+ → ---
feature-b2g: --- → 2.5+
(Assignee)

Comment 11

2 years ago
Created attachment 8664367 [details] [diff] [review]
Add a comma to the asterisk button on the keypad.

Comment 12

2 years ago
Created attachment 8664368 [details] [review]
[gaia] DouglasSherk:1163834-keypad-comma > mozilla-b2g:master
(Assignee)

Updated

2 years ago
Attachment #8664368 - Flags: review?(gsvelto)
(Assignee)

Updated

2 years ago
Status: NEW → ASSIGNED
Comment on attachment 8664368 [details] [review]
[gaia] DouglasSherk:1163834-keypad-comma > mozilla-b2g:master

LGTM
Attachment #8664368 - Flags: review?(gsvelto) → review+
(Assignee)

Comment 14

2 years ago
https://github.com/mozilla-b2g/gaia/commit/e1c36f537acf9b739205019fd6bde191f69fa1d5
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
status-b2g-master: affected → fixed
Resolution: --- → FIXED
This bug has been verified as "pass" on the latest build of Flame KK 2.5 and Aires KK 2.5 by the STR in comment 0.

Actual results: The asterisk key on the keypad has a blue comma (,) symbol to indicate long press functionality.
See attachment: verified_Flame_v2.5.png
Reproduce rate: 0/10


Device: Flame KK 2.5 (Pass)
Build ID               20150927150205
Gaia Revision          285486b417f1cb8316b19c0698a6655fc053fbd6
Gaia Date              2015-09-25 14:11:30
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/6256ec9113c115141aab089c45ee69438884b680
Gecko Version          44.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150927.184956
Firmware Date          Sun Sep 27 18:50:08 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Aries KK 2.5 (Pass)
Build ID               20150927001555
Gaia Revision          285486b417f1cb8316b19c0698a6655fc053fbd6
Gaia Date              2015-09-25 14:11:30
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/6256ec9113c115141aab089c45ee69438884b680
Gecko Version          44.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20150926.233607
Firmware Date          Sat Sep 26 23:36:15 UTC 2015
Bootloader             s1
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][MGSEI-Triage+]
status-b2g-master: fixed → verified
Created attachment 8666592 [details]
verified_Flame_v2.5.png
You need to log in before you can comment on or make changes to this bug.