Autocomplete city, region and country based on longitude and latitude.

RESOLVED WONTFIX

Status

Mozilla Reps
reps.mozilla.org
RESOLVED WONTFIX
3 years ago
6 months ago

People

(Reporter: tasos, Assigned: tasos)

Tracking

Details

(Whiteboard: [kb=1746420] )

(Assignee)

Description

3 years ago
City, region and country fields in a user's profile are free forms and a user can input a different set than the one that emerges from the lon and lat coordinates. The free forms should be marked as read-only and can be auto populated from the reverse geolocation.
(Assignee)

Updated

3 years ago
Whiteboard: [kb=1746420]
(Assignee)

Comment 1

3 years ago
Marking this as wontfix because this issue will be tackled by syncing location data from the mozillians.org profile of a user through an API request.
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX

Comment 2

6 months ago
(In reply to Tasos Katsoulas [:tasos] from comment #1)
> Marking this as wontfix because this issue will be tackled by syncing
> location data from the mozillians.org profile of a user through an API
> request.

I am not able to enter my country because of autocomplete issues. Due to this, my Mozillians profile is unable to complete. Also, there are CORS issues for the API calls. Maybe that's the bug?
(Assignee)

Comment 3

6 months ago
Hi Aditya,

Are you having problems completing your profile in mozillians.org or in reps.mozilla.org? Can you share some additional information about the problem? What kind of autocomplete issues are you having? Also a screenshot of the problem would help to debug this issue.

Thanks!

Comment 4

6 months ago
Hello Tasos,

I am having problems in the profile completion in mozillians.org. After logging in, they ask me to complete the profile (since I signed up for the first time). The problem is at the 'Country' section where I type my country (India) but it doesn't show up.

Bug Image URL : https://pasteboard.co/2dOZaX8sH.png

This is same in the cases of 'Region' & 'City' sections. I checked in the DevTools console & it says that there are CORS issues with the API.

Comment 5

6 months ago
(In reply to Aditya Krishnakumar from comment #4)
> Hello Tasos,
> 
> I am having problems in the profile completion in mozillians.org. After
> logging in, they ask me to complete the profile (since I signed up for the
> first time). The problem is at the 'Country' section where I type my country
> (India) but it doesn't show up.
> 
> Bug Image URL : https://pasteboard.co/2dOZaX8sH.png
> 
> This is same in the cases of 'Region' & 'City' sections. I checked in the
> DevTools console & it says that there are CORS issues with the API.

Also, Here is the Console errors specific to the autocomplete

URL : https://pasteboard.co/2dZK02T0k.png

There were 28 errors shown in console
Tasos, this was the bug fixed yesterday, right? Do we still want to update it's description, status (WONTFIX is probably wrong) and publish a Post Mortem on Discourse?

-Henrik
Flags: needinfo?(tasos)

Comment 7

6 months ago
(In reply to Henrik Mitsch [:hmitsch] from comment #6)
> Tasos, this was the bug fixed yesterday, right? Do we still want to update
> it's description, status (WONTFIX is probably wrong) and publish a Post
> Mortem on Discourse?
> 
> -Henrik

The bug has been fixed. Thanks

Comment 8

6 months ago
Can I be vouched for reporting this bug? I am new to Mozillans.org and this is my first bug reporting
(Assignee)

Comment 9

6 months ago
This bug should stay as WONTFIX because it's for the ReMo portal and not for mozillians.org. It's marked as WONTFIX because what was listed in the initial description is no longer relevant to the ReMo portal
Flags: needinfo?(tasos)
You need to log in before you can comment on or make changes to this bug.