[Download Manager]The "Try again" is truncated on "Download stopped" dialog screen.

VERIFIED DUPLICATE of bug 1160096

Status

defect
VERIFIED DUPLICATE of bug 1160096
4 years ago
4 years ago

People

(Reporter: yue.xia, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.2 verified)

Details

(Whiteboard: LocRun2.2)

Attachments

(5 attachments)

(Reporter)

Description

4 years ago
[1.Description]:
[Flame v2.2][Download Manager]When you are downloading a file, enter "Downloads" to stop it and tap try again icon, the "Try again" is truncated on "Download stopped" dialog screen.
See attachment: 
Bengali India_Try again.png
Polish_Try again.png
Portuguese Brazil_Try again.png
Portuguese Portugal_Try again.png

[2.Testing Steps]: 
1. Launch Settings app and change the language to Polish.
2. Connect to a wifi.
3. Launch Browser app and download a file from website.
4. During downloading, enter Settings app -> enter "Downloads".
5. Tap "x" icon to stop downloading and tap "Yes".
6. Tap the try again icon

[3.Expected Result]: 
6. The "Try again" should not be truncated on "Download stopped" dialog screen.

[4.Actual Result]: 
6. The "Try again" is truncated on "Download stopped" dialog screen.

[5.Reproduction build]: 
Device: Flame2.1 user (Unaffected)
Build ID               20150511001203
Gaia Revision          3e7bd686ecd852f4dfa4605b45f558e6bd34f02a
Gaia Date              2015-05-07 15:12:34
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/de4ebfdc7db6
Gecko Version          34.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150511.033638
Firmware Date          Mon May 11 03:36:49 EDT 2015
Bootloader             L1TC000118D0

Device: Flame2.2 user (Affected)
Build ID               20150511162500
Gaia Revision          c4c1bf443f2b01c2ba918780510fd4c639a3c360
Gaia Date              2015-05-11 14:12:24
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/70782f19acbf
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150511.195649
Firmware Date          Mon May 11 19:56:59 EDT 2015
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test

[8.Note]:
* This problem cannot be reproduced in language of  Spanish, Serbian Cyrillic, Russian, Greek, Basque, Arabic.
* This problem can be reproduced in language of Bengali India, Polish, Portuguese Brazil and Portuguese Portugal.
(Reporter)

Comment 1

4 years ago
Posted image Polish_Try again.png
Regression so blocking 2.2.
blocking-b2g: --- → 2.2+
Keywords: regression
This should be a dupe of bug 1160096, which is fixed on master. Can we verify when that gets uplifted to v2.2?
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1160096
Thanks Sam! Adding verifyme keyword so that once bug 1160096 lands on 2.2, QA can make sure everything's looking good!
Keywords: verifyme
According to the STR in comment 0, this issue is verified pass on latest Flame 2.2 user build in Bengali India, Polish, Portuguese Brazil and Portuguese Portugal languages, the "Try again" is displayed without truncation on "Download stopped" dialog screen.
See attachment: Verify1_Try again_v2.2_Pass.png.
Reproducing rate:0/10

Flame 2.2 user build (Pass)
Build ID               20150602162502
Gaia Revision          a9aeb08263f1a727136e8ae78425e52431c82770
Gaia Date              2015-06-02 13:04:40
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/5b3f1796ddf6
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150602.195222
Firmware Date          Tue Jun  2 19:52:31 EDT 2015
Bootloader             L1TC000118D0
Status: RESOLVED → VERIFIED
QA Whiteboard: [MGSEI-Triage+][MGSEI-l10n-1F]
Keywords: verifyme
Whiteboard: LocRun2.2,MGSEI-l10n-1F → LocRun2.2
You need to log in before you can comment on or make changes to this bug.