If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Height scaling of text input elements broken inside of tables

RESOLVED DUPLICATE of bug 114901

Status

()

Core
Layout: Form Controls
RESOLVED DUPLICATE of bug 114901
16 years ago
16 years ago

People

(Reporter: Jim Kilmer, Assigned: rods (gone))

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.6+) 
Gecko/20011219

Text input boxes inside table cells have their height scaling calculated 
improperly when setting height=100% with CSS.  The problem occurs when the 
prevailing text height of the table row is smaller than the combined height of 
the input box's text size and padding/borders.

In the attached test case, if you remove the {height: 100%} attribute on 
class .data, then the text box scales properly in the first table, since the 
total row height is greater than the 14px specified for the text in the row.  
However, in the second table, the input box then fails to fill the cell when 
that is done.

In the second table of the test case, as posted, the input box scales properly 
when the row's text size is larger than the input box's text size plus 
padding/borders.  

IE shows the expected behavior in both cases: scaling the table cell up when 
the row is shorter than the necessary size to accommodate the input box, and 
scaling the input box up when the table cell is larger than the input box.
(Reporter)

Comment 1

16 years ago
Created attachment 62528 [details]
Testcase for broken vertical scaling

Comment 2

16 years ago

*** This bug has been marked as a duplicate of 114901 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.