Closed Bug 1164131 Opened 5 years ago Closed 5 years ago

[regression] CallTree does not display files with port names in URL correctly

Categories

(DevTools :: Performance Tools (Profiler/Timeline), defect, P1)

37 Branch
defect

Tracking

(firefox40 verified, firefox41 fixed)

VERIFIED FIXED
Firefox 41
Tracking Status
firefox40 --- verified
firefox41 --- fixed

People

(Reporter: jsantell, Assigned: jsantell)

References

(Blocks 1 open bug)

Details

(Whiteboard: [polish-backlog])

Attachments

(2 files)

Assignee: nobody → jsantell
Status: NEW → ASSIGNED
Whiteboard: [devedition-40]
Not just for imports, but for any local file
Summary: [regression] Importing profiler v2 does not display fileName in calltree → [regression] Local files do not have correct fileName in call tree
AHAHAHhahahhah T_T
Related to port number. Previously worked in most common cases, fixing to work in all port cases. Adding "port" and "host" (combo of hostName:port) to parseLocation return.
Summary: [regression] Local files do not have correct fileName in call tree → [regression] CallTree does not display files with port names in URL correctly
Priority: -- → P1
Fixed the issue and did infact test with inline scripts on root's that contain port numbers, and we do get a `/` after the port. Added tests for all of these cases, and we now use `host` instead of just `hostName`.

https://treeherder.mozilla.org/#/jobs?repo=try&revision=80f14fdff166
Attachment #8604923 - Flags: review?(shu)
Comment on attachment 8604923 [details] [diff] [review]
1164131-calltreeports.patch

Review of attachment 8604923 [details] [diff] [review]:
-----------------------------------------------------------------

::: browser/devtools/shared/profiler/frame-utils.js
@@ +150,5 @@
> +        port = uri.port === -1 ? null : uri.port;
> +        host = port !== null ? `${hostName}:${port}` : hostName;
> +      } catch (e) {
> +        host = hostName;
> +      }

I don't like this, but I'll live with it. The answer I got from Jonas was that our default implementation of nsIURI doesn't throw for .port, but addons can do what they want since they can implement nsIURI. As long as we don't throw 99% of the time, this is fine.
Attachment #8604923 - Flags: review?(shu) → review+
Hoping that 1160581 will render this moot
https://hg.mozilla.org/mozilla-central/rev/7f901174dd44
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Whiteboard: [devedition-40][fixed-in-fx-team] → [devedition-40]
Target Milestone: --- → Firefox 41
Flags: qe-verify+
Comment on attachment 8604923 [details] [diff] [review]
1164131-calltreeports.patch


Approval Request Comment
[Feature/regressing bug #]: 1167252, the new performance tool
[User impact if declined]: Won't ship the performance tool
[Describe test coverage new/current, TreeHerder]: There are try pushes in Bug 1167252 with all patches needing uplift
[Risks and why]: Requesting uplift for the accumulated changes in the performance tool since the 40 merge date, so these changes haven't had the full 6 weeks to bake.  Risks are generally contained within devtools, specifically within the performance panel.
[String/UUID change made/needed]: None
Attachment #8604923 - Flags: approval-mozilla-aurora?
Note: I had verbal confirmation for these uplifts from Sylvestre even before he's flagged them as a+.  See https://bugzilla.mozilla.org/show_bug.cgi?id=1167252#c26
Comment on attachment 8604923 [details] [diff] [review]
1164131-calltreeports.patch

Change approved to skip one train as part of the spring campaign.
Attachment #8604923 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Verified fixed on Aurora 40.0a2 (2015-06-04), using Ubuntu 14.04 (x64), Windows 7 (x64) and Mac OS X 10.9.5.

Call Tree now properly displays the files from URL's containing port names, e.g. http://i.imgur.com/8BMUtaL.png.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
Whiteboard: [devedition-40] → [polish-backlog]
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.