HTML only save does the same as complete save in Linux

VERIFIED FIXED in mozilla0.9.8

Status

Core Graveyard
File Handling
P1
major
VERIFIED FIXED
16 years ago
a year ago

People

(Reporter: Jeremy M. Dolan, Assigned: dbaron)

Tracking

({dataloss, pp})

Trunk
mozilla0.9.8
x86
Linux
dataloss, pp
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
2001122108 Linux. uselessui/dataloss/pp/otherfunstuff

Comment 1

16 years ago
File | Save As HTML only saves with images, css, etc. rather than saving just
the plain html. Seems to be linux only. works fine for me on windows 0.9.7
branch build fails on linux 097 branch build. 

Steps to repro:
1. load an html page
2. select File | Save as
3. select Web Page, HTML only (*.htm, *.html)

Results:
the entire page is saved with images, css, etc. This is the behavior expected
from the "Web Page, complete" option.

Expected results:
just the html should be saved.
Keywords: pp
Summary: HTML only save does the same as complete save in Linux (pp?) → HTML only save does the same as complete save in Linux

Comment 2

16 years ago
I just added a comment saying this to bug 115088 which might be related.
Blocks: 115634

Comment 3

16 years ago
Is this a dupe of bug 115088?
This is a dataloss bug.  Saving as HTML only should not munge the HTML (which it 
does while this bug exists).  Upgrading to major.  This effectively makes saving 
files, editing, and reuploading impossible with Mozilla on linux.
Severity: normal → major
Keywords: dataloss

Comment 5

16 years ago
->critical/0.9.8/p1 (data loss)
Severity: major → critical
Priority: -- → P1
Target Milestone: --- → mozilla0.9.8
i don't understand how is this different from bug 115088. could someone pls
explain? thx! [either way, both bugs are very annoying.]
Keywords: nsbeta1
It may well be the same.  When I filed bug 115088 saving whole page was broken 
on linux, so both options behaved identically.  I bet 115088 is just a dup of 
this (this has a better clearer summary).
Blocks: 115088
*** Bug 115088 has been marked as a duplicate of this bug. ***
from 115088: this is also a problem for trying to save the page as text only.
unfortunately, i no longer see that option. filed bug 117491 for that issue.
No longer blocks: 115088
*** Bug 117593 has been marked as a duplicate of this bug. ***

Comment 11

16 years ago
*** Bug 118346 has been marked as a duplicate of this bug. ***

Comment 12

16 years ago
*** Bug 118531 has been marked as a duplicate of this bug. ***
Status: NEW → ASSIGNED
(Assignee)

Updated

16 years ago
Blocks: 115520
(Assignee)

Comment 13

16 years ago
Created attachment 65058 [details] [diff] [review]
fix
(Assignee)

Comment 14

16 years ago
Taking
Assignee: ben → dbaron
Status: ASSIGNED → NEW
(Assignee)

Updated

16 years ago
Severity: critical → major
Status: NEW → ASSIGNED
Comment on attachment 65058 [details] [diff] [review]
fix

Wow.  typos all over....
r=bzbarsky.  Looks good, works well.
Attachment #65058 - Flags: review+
Comment on attachment 65058 [details] [diff] [review]
fix

I spy an else after return in the filepicker.js patch (fix for bonus points).

sr=brendan@mozilla.org, thanks for fixing this.

/be
Attachment #65058 - Flags: superreview+
(Assignee)

Comment 17

16 years ago
Fix checked in 2002-01-15 16:41 (with else-after-return converted to returning
the boolean directly).
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
*** Bug 120452 has been marked as a duplicate of this bug. ***
saving as "html only" and "text only" works fine with 2002.01.24.08 comm bits on
linux rh7.2.
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.