a way to exclude "Future" from the query

RESOLVED WORKSFORME

Status

()

Bugzilla
Query/Bug List
--
enhancement
RESOLVED WORKSFORME
16 years ago
5 years ago

People

(Reporter: Frank Tang, Assigned: Nobody's working on this, feel free to take it)

Tracking

Details

(Reporter)

Description

16 years ago
currently, when I query bugzilla, it is very hard to produce a list which
exclude a particulare milestone, for example, I constantly need to query any bug
those I put into "future" milestone.  If I select every milestone and deselect
the "Future" one, then the query is broken (I think there are some length
limitation) I want a way to exclude "Future" milestone.

Comment 1

16 years ago
I tried this with a query for open bugs in product=Browser,
component=Internationalization, using Mozilla 0.9.7.

- Without any additional constraints/conditions, I got 413 bugs.

- When I clicked the back button and selected all target milestones except
Future, I got nearly 9000 bugs, but then I discovered that this was due to a bug
with the javascript code for component selection: In the current version on
bugzilla.mozilla.org, the component selection is cleared on back. I think this
is bug 83033.

- After reselecting component=Internationalization and selecting all milestones
 except Future, I get 229 bugs, which is a plausible result.

- Alternatively, you can perform an "Advanced Query using Boolean Charts" with
the condition ("Target Milestone", "not equal to", "Future"). Again, the result
is 229 bugs.

Based on these tests, I think this is either worksforme or a dupe of bug 83033.
There is a good point about exclusion, especially given you might add new things
and they wouldn't be included when they should.

However all this applies equally well to all fields.  I would be very hesitant
to add an exclusion checkbox to each field.

And as stated, this can be done via advanced query.  Moving to Future and we'll
see if any better ideas come up.
Target Milestone: --- → Future

Updated

15 years ago
OS: Linux → All
Hardware: PC → All
Severity: normal → enhancement
Assignee: endico → nobody

Comment 3

13 years ago
There are two ways to get this functionality: 
1) One can deselect all the milestones (or insert-other-picklist) except the
   ones you want, and run the query. This works just fine for me.

2) One can use the Advanced Searching Using Boolean Charts and select 
   "Target Milestone|is not equal to|Future" 
   (or even "NOT "Target Milestone|is equal to|Future" if you want)

Both/all three of these methods return the same number of bugs for me. If you 
need to exclude more than just one thing, then remove the extra items from the 
picklist too (using control-click), or add another item to the boolean search.

This is more than enough functionality to cover the original request. 
Marking as WORKSFORME.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
clearing target of DUPLICATE/WONTFIX/INVALID/WORKSFORME so they'll show up as
untriaged if they get reopened.
Target Milestone: Future → ---
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.