bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Travis-CI runs on the tools repos are failing with git docker config errors

RESOLVED DUPLICATE of bug 1164256

Status

Infrastructure & Operations
CIDuty
P1
critical
RESOLVED DUPLICATE of bug 1164256
3 years ago
2 months ago

People

(Reporter: RyanVM, Unassigned)

Tracking

Details

(Reporter)

Description

3 years ago
I pushed two changes to the tools repo and hit the following failures:
----------------------
*** Please tell me who you are.

Run

  git config --global user.email "you@example.com"

  git config --global user.name "Your Name"

to set your account's default identity.

Omit --global to set the identity only in this repository.

fatal: empty ident name (for <travis@testing-worker-linux-docker-911514be-3262-linux-5.prod.travis-ci.org>) not allowed

fatal: Failed to resolve 'HEAD' as a valid ref.
----------------------

https://travis-ci.org/mozilla/build-tools/jobs/62309879

The failures have persisted even after backing out both changes, so it appears to be a configuration issue rather than a problem with the patches I landed.
(Reporter)

Updated

3 years ago
Priority: -- → P1
(Reporter)

Comment 1

3 years ago
Filing race.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1164256

Updated

2 months ago
Product: Release Engineering → Infrastructure & Operations
You need to log in before you can comment on or make changes to this bug.