colons in anchor tags improperly interpreted

VERIFIED FIXED in M10

Status

()

Core
Networking
P3
normal
VERIFIED FIXED
19 years ago
17 years ago

People

(Reporter: Dan Rosen, Assigned: Gagan)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Colons in anchor tags (eg. <a href="#my::anchor">) are interpreted strangely as
fully-qualified urls (eg. "my:///"). I'm not sure whether this is a parser
problem (which is what I filed it under) or a "browser-general" problem, but I
do know that anchors like this work in navigator 4.6.

Updated

19 years ago
Assignee: rickg → warren
Component: Parser → Necko

Comment 1

19 years ago
Warren -- I think you own the URL stuff now, right? If not please forward to
correct owner.

Updated

19 years ago
Assignee: warren → gagan

Comment 2

19 years ago
Gagan owns this now.
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M10

Updated

19 years ago
Blocks: 13449

Comment 3

19 years ago
I have a fix for this, wainting for review

Comment 4

19 years ago
fix checked in ...
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 5

19 years ago
thanks andreas.

Comment 6

18 years ago
Bulk move of all Necko (to be deleted component) bugs to new Networking

component.

Comment 7

18 years ago
networking == tever
changing qa contact
QA Contact: janc → tever

Comment 8

17 years ago
verified
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.