Closed Bug 1164357 Opened 7 years ago Closed 7 years ago

[Message]The UI looks broken and home button is invalid after sending a message to a number that is not an Authorized number of FDN.

Categories

(Firefox OS Graveyard :: Gaia::System::Input Mgmt, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:2.5+, b2g-v2.2 unaffected, b2g-master verified)

VERIFIED FIXED
2.2 S12 (15may)
blocking-b2g 2.5+
Tracking Status
b2g-v2.2 --- unaffected
b2g-master --- verified

People

(Reporter: lulu.tian, Assigned: timdream)

References

Details

(Keywords: regression, smoketest, Whiteboard: [3.0-nexus-5-l])

Attachments

(2 files)

548.61 KB, text/plain
Details
4.98 MB, video/mp4
Details
Attached file logcat_1415.txt
[1.Description]:
[Flame 3.0][Nexus 5 3.0][Message]The UI looks broken and home button is invalid after sending a message to a number that is not an Authorized number of FDN when FDN is enabled.
Found time:14:15
See attachment:video.mp4 and logcat_1415.txt

[2.Testing Steps]: 
Prerequisite: Enable Fixed Dialing Numbers.
1. Launch Message.
2. Send a massage to a number that is not an Aunthorized number of FDN.
3. Observe the view.
4. Tap Home button.

[3.Expected Result]: 
3. The UI of message view should not be broken.
4. It should go back to home screen.

[4.Actual Result]: 
3. The half bottom of screen displays as black.
4. There is no response.

[5.Reproduction build]: 
Device: Flame 2.2 (unaffected)
Build ID               20150512002502
Gaia Revision          c4c1bf443f2b01c2ba918780510fd4c639a3c360
Gaia Date              2015-05-11 14:12:24
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/70782f19acbf
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150512.041644
Firmware Date          Tue May 12 04:16:55 EDT 2015
Bootloader             L1TC000118D0

Device: Flame 3.0 (affected)
Build ID               20150512160203
Gaia Revision          3654ec1d7ce1e0a56a34d5c3b06f6a9b33ff79ad
Gaia Date              2015-05-12 05:13:33
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/42db79f3cd6b
Gecko Version          41.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150512.192015
Firmware Date          Tue May 12 19:20:26 EDT 2015
Bootloader             L1TC000118D0

Device: Nexus 5 2.2 (unaffected)
Build ID               20150512162502
Gaia Revision          e048df68f6f4853b5826a8816e143d95258149de
Gaia Date              2015-05-12 19:10:26
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/9edadb35caca
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150512.202258
Firmware Date          Tue May 12 20:23:14 EDT 2015
Bootloader             HHZ12f

Device: Nexus 5 3.0 (affected)
Build ID               20150512160203
Gaia Revision          3654ec1d7ce1e0a56a34d5c3b06f6a9b33ff79ad
Gaia Date              2015-05-12 05:13:33
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/42db79f3cd6b
Gecko Version          41.0a1
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150512.191625
Firmware Date          Tue May 12 19:16:41 EDT 2015
Bootloader             HHZ12f

[6.Reproduction Frequency]: 
occasionally Recurrence,6/10

[7.TCID]: 
Free Test
Attached video video.mp4
Note: you need to download the video to be able to read it.
Requesting the regression window since it's master only issue. Another easier way to reproduce this issue is enable the airplane mode and send message.

Hi Alive, it seems the window didn't resize properly after keyboard dismissed, and the weird thing is the app could not move to background by pressing home button when window is broken already.
Component: Gaia::SMS → Gaia::System::Window Mgmt
Flags: needinfo?(alive)
Very likely caused by bug 1162383.

05-13 14:15:19.136 I/GeckoDump(  195): [system] [InputWindow][Built-in Keyboard][InputWindow_3][21295.078] kbHide has been ENDED!

05-13 14:15:19.136 I/GeckoDump(  195): [system] [InputWindow][Built-in Keyboard][InputWindow_3][21295.078] closing,closed,::,complete

05-13 14:15:19.137 I/GeckoDump(  195): [system] [InputWindow][Built-in Keyboard][InputWindow_3][21295.079] publishing internal event: closed

05-13 14:15:19.138 I/GeckoDump(  195): [system] [InputWindow][Built-in Keyboard][InputWindow_3][21295.080] publishing external event: closed

05-13 14:15:19.138 I/GeckoDump(  195): [system] [InputWindow][Built-in Keyboard][InputWindow_3][21295.080] setAsActiveInput: app://keyboard.gaiamobile.org/manifest.webapp/index.html#en, active: false

05-13 14:15:19.138 I/GeckoDump(  195): [system] [InputWindow][Built-in Keyboard][InputWindow_3][21295.080] set visibility -> ,false

05-13 14:15:19.139 I/GeckoDump(  195): [system] [InputWindow][Built-in Keyboard][InputWindow_3][21295.081] setActive on browser element:false

05-13 14:15:19.140 I/GeckoDump(  195): [system] [HierarchyManager][21295.082] getting top most...,[object Object]

05-13 14:15:19.141 I/GeckoDump(  195): [system] [InputWindow][Built-in Keyboard][InputWindow_3][21295.083] before hiding frame

05-13 14:15:19.141 I/GeckoDump(  195): [system] [InputWindow][Built-in Keyboard][InputWindow_3][21295.083] setVisible on browser element:false

05-13 14:15:19.146 I/GeckoDump(  195): [system] [HierarchyManager][21295.088] windowclosed

05-13 14:15:19.147 I/GeckoDump(  195): [system] [InputWindow][Built-in Keyboard][InputWindow_3][21295.089] publishing internal event: close

05-13 14:15:19.147 I/GeckoDump(  195): [system] [InputWindow][Built-in Keyboard][InputWindow_3][21295.089] publishing external event: close

Looks like the close of InputWindow does not trigger the top most window to resize.
Component: Gaia::System::Window Mgmt → Gaia::System::Input Mgmt
Flags: needinfo?(alive) → needinfo?(timdream)
Taken, thanks for needinfo.
Assignee: nobody → timdream
Status: NEW → ASSIGNED
blocking-b2g: --- → 3.0+
Flags: needinfo?(timdream)
I don't know which part of the logs are turned on in logcat (yet another reason we need a consistent logging policy ...), but the |nextpainted| in the log implies the app window has already resized. Shouldn't the dialog (is it an alert()?) adopt the new size too?
Duplicate of this bug: 1164493
Let's confirm Comment 3 for the window. This is a sanity blocker.
QA Contact: pcheng
b2g-inbound regression window:

Last Working
Device: Flame
BuildID: 20150511070742
Gaia: f8f16cab4554dde9af2a655213e7c310bbec156c
Gecko: 9858f9e8dbb9
Version: 40.0a1 (3.0 Master) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

First Broken
Device: Flame
BuildID: 20150511104718
Gaia: fdc331adfa64d4dc7d2b2dfee8a8889388480d7b
Gecko: 9eb3935a1fc3
Version: 40.0a1 (3.0 Master) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

Last Working Gaia First Broken Gecko - no repro
Gaia: f8f16cab4554dde9af2a655213e7c310bbec156c
Gecko: 9eb3935a1fc3

Last Working Gecko First Broken Gaia - repro
Gaia: fdc331adfa64d4dc7d2b2dfee8a8889388480d7b
Gecko: 9858f9e8dbb9

Gaia pushlog:
https://github.com/mozilla-b2g/gaia/compare/f8f16cab4554dde9af2a655213e7c310bbec156c...fdc331adfa64d4dc7d2b2dfee8a8889388480d7b

Bug 1162383 seems most likely to be the cause.
Blocks: 1162383
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Timothy, can you take a look at this please? Looks like this was caused by the landing for bug 1162383. We may need this backed out since this is a smoketest blocker.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(timdream)
(In reply to Naoki Hirata :nhirata (please use needinfo instead of cc) from comment #10)
> Backed out :
> https://github.com/mozilla-b2g/gaia/commit/
> 1eedfcc2762d583daf2ceb31d8f73e2224f07a31

Thanks. I would choose to backout the patch too. It's sad that we are not protected by tests in this case.
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Flags: needinfo?(timdream)
Resolution: --- → FIXED
This issue is Verified Fixed in the latest Flame 3.0 build.
UI and home button remain functional after sending a message and dismissing the keyboard.

Environmental Variables:
Device: Flame 3.0 (319MB)(Full Flash)
Build ID: 20150515010201
Gaia: 8897e1810aa6426ca483269af76ce2bfd2029d25
Gecko: 25c5525a1000
Gonk: 040bb1e9ac8a5b6dd756fdd696aa37a8868b5c67
Version: 41.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga)
Target Milestone: --- → 2.2 S12 (15may)
You need to log in before you can comment on or make changes to this bug.