[e10s] Disable "disable flash protected mode" functionality under e10s

RESOLVED WONTFIX

Status

()

Firefox
General
RESOLVED WONTFIX
3 years ago
2 years ago

People

(Reporter: jimm, Assigned: jimm)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(e10s+, firefox41 affected)

Details

Attachments

(1 attachment)

(Assignee)

Description

3 years ago
Since we don't know if this helps or hurts with e10s we should turn this off so it doesn't trigger when e10s is running. Unfortunately once this pref is set it looks like it stays that way so we'll still get this under e10s if someone was prompted under non-e10s. But that's out of our control. At least we can stop from triggering it for now.
(Assignee)

Comment 1

3 years ago
Created attachment 8605275 [details] [diff] [review]
patch
Assignee: nobody → jmathies
Attachment #8605275 - Flags: review?(aklotz)

Comment 2

3 years ago
I don't understand.
tracking-e10s: --- → +

Updated

3 years ago
Attachment #8605275 - Flags: review?(aklotz) → review+
This patch looks okay, but like bsmedberg I am a bit unsure as to the necessity of this. Have there been problems?
(Assignee)

Comment 4

3 years ago
(In reply to Aaron Klotz [:aklotz] (please use needinfo) from comment #3)
> This patch looks okay, but like bsmedberg I am a bit unsure as to the
> necessity of this. Have there been problems?

I'm unsure of the necessity of turning flash protected mode off. :) I'd like to assume that whatever bug we tried to fix with this isn't present with e10s enabled, or if it is present, we can look at fixing it in a better way. In the mean time my goal here is to simply disable this so that it doesn't cause problems or confusing when we debug flash deadlock issues.
(Assignee)

Comment 5

3 years ago
s/confusing/confusion

Comment 6

3 years ago
We know that the majority of the Flash deadlock issues are caused by protected mode, and I wouldn't expect that to be much better with e10s. I think having this checkbox continue to work and being able to test whether a particular deadlock scenario only happens with protected mode enabled would be quite valuable.
(Assignee)

Comment 7

3 years ago
(In reply to Benjamin Smedberg  [:bsmedberg] from comment #6)
> We know that the majority of the Flash deadlock issues are caused by
> protected mode, and I wouldn't expect that to be much better with e10s.

e10s deadlock rates are about 1/3 that of non-e10s so there are differences in behavior here. I think establishing a baseline with protected mode (and testing with it off using about:config occasionally) is a good approach. e10s + least-supported flash mode seems like a bad place to start from.

> I think having this checkbox continue to work and being able to test whether a
> particular deadlock scenario only happens with protected mode enabled would
> be quite valuable.

My patch disables auto-disable of protected mode but not the pref, so we can continue to test using this.
(Assignee)

Comment 8

3 years ago
Do we have any idea how many users have this set?

Comment 9

3 years ago
I don't understand what "My patch disables auto-disable of protected mode but not the pref" means. The patch disables the functionality of the pref when e10s is enabled.

Hopefully only a few people will have the pref set: people who have come to SUMO because of persistent Flash hangs and were directed to use the checkbox to make the problem better.
Is this issue still in the works or could this be closed?
(Assignee)

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.