If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Make android GDB setup work with emulator builds

RESOLVED DUPLICATE of bug 1219807

Status

Testing
General
RESOLVED DUPLICATE of bug 1219807
2 years ago
2 years ago

People

(Reporter: bholley, Assigned: gbrown)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Brad says that he will resource this once we get emulator mochitests hooked up to mach, which is bug 1164596.
(Assignee)

Comment 1

2 years ago
I recently verified that gdb (JimDB) works fine with the Android emulator, and the coming-soon "mach emulator" command. https://wiki.mozilla.org/Mobile/Fennec/Android/GDB is helpful.

JimDB has support for running mochitests, and that too works fine with the emulator: work through the JimDB prompts and mochitests are launched on the emulator, with the debugger running.

I would like to see mach support for downloading and installing JimDB, similar to "mach emulator" - I can do that.

To make things even more simple and discoverable, it would be great if we could integrate JimDB with "mach mochitest", but I can't quite visualize that, yet.
(In reply to Geoff Brown [:gbrown] from comment #1)
> I recently verified that gdb (JimDB) works fine with the Android emulator,
> and the coming-soon "mach emulator" command.
> https://wiki.mozilla.org/Mobile/Fennec/Android/GDB is helpful.

Last I checked this wasn't the case, and I had to modify a bunch of the python scripts to get it to partially work. I guess that's been fixed?
(In reply to Geoff Brown [:gbrown] from comment #1)
> I would like to see mach support for downloading and installing JimDB,
> similar to "mach emulator" - I can do that.
> 
> To make things even more simple and discoverable, it would be great if we
> could integrate JimDB with "mach mochitest", but I can't quite visualize
> that, yet.

Those both sound great. Also, when things are a mach command, the developer _knows_ it's supposed to a supported use-case, and is more confident filing bugs when it doesn't work.
:snorp has patches that let us run jimdb python scripts inside the gdb that's included in the NDK. That would make it a lot easier to run jimdb since the user should already have a copy of the NDK installed.
(Assignee)

Updated

2 years ago
Assignee: nobody → gbrown
(Assignee)

Comment 5

2 years ago
(In reply to Jim Chen [:jchen] [:darchons] from comment #4)
> :snorp has patches that let us run jimdb python scripts inside the gdb
> that's included in the NDK. That would make it a lot easier to run jimdb
> since the user should already have a copy of the NDK installed.

Let's see these patches.
Flags: needinfo?(snorp)
(Assignee)

Updated

2 years ago
Depends on: 1219807
(Assignee)

Comment 6

2 years ago
(In reply to Geoff Brown [:gbrown] from comment #5)
> Let's see these patches.

Sounds interesting, but I'm not going to get into that. In bug 1219807, I deployed jimdb binaries to tooltool, for use from mach -- good enough for me.
Flags: needinfo?(snorp)
(Assignee)

Comment 7

2 years ago
This ended up being implemented in bug 1219807. mach can download, configure and run jimdb and jimdb can debug Firefox on a phone, tablet, or emulator.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1219807
You need to log in before you can comment on or make changes to this bug.