Firefox consumes cpu while idle and in the background (win10, preview build 10074)

RESOLVED WORKSFORME

Status

()

Firefox
General
P2
normal
RESOLVED WORKSFORME
3 years ago
2 years ago

People

(Reporter: jimm, Unassigned)

Tracking

(Blocks: 1 bug)

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
STR:

1) open firefox, either in desktop or tablet mode
2) open task manager, placing fx in the background

In desktop mode fx consumes around 2-3% cpu constantly for me. In tablet mode anywhere from 3-10%.

tested on a surface pro 2.
Priority: -- → P1
Are you still seeing this? I couldn't reproduce this on either my VM or my Surface Pro 3. I took a profile using the devtools toolbox, and found essentially nothing in it apart from the devtools protocol overhead and periodic GCs.

I don't think this should be P1, as without further info, it's very unlikely to be either windows-specific or win10-specific.
Flags: needinfo?(jmathies)
(Reporter)

Comment 2

2 years ago
I see a lot of activity over the first minute or so then things seem to calm down.
Flags: needinfo?(jmathies)
We should double check this with the most recent build.
Priority: P1 → P2

Comment 4

2 years ago
needinfo for comment 3
Flags: needinfo?(jmathies)
(Reporter)

Comment 5

2 years ago
Seems ok in build 10162. I see discrete increases occasionally but I'm guessing that's just background tasks.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(jmathies)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.