If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Surface warn before quitting pref for Mac users

RESOLVED DUPLICATE of bug 645338

Status

()

Firefox
Preferences
RESOLVED DUPLICATE of bug 645338
3 years ago
a year ago

People

(Reporter: sphilp, Unassigned)

Tracking

38 Branch
Unspecified
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8605583 [details]
Screen Shot 2015-05-13 at 7.47.23 PM.png

This request is for similar functionality to Chrome's "Warn Before Quitting" app menu item, see screenshot, 3rd item from the bottom.

On OSX, hitting CMD-Q force quits Firefox without a prompt. There is a pref to turn on a prompt, browser.showQuitWarning, but I don't see it exposed anywhere in the settings or the app menu (where most regular users would look for it). We should surface this pref so more Mac users will see it.

There's some related discussion in bug 565567 about having the prompt vs the existing session state stuff, but this new bug is purely about surfacing the prompt pref in the app menu (or in the main settings somewhere). 

Reasoning: Some users will prefer to have Firefox not remember session state, but also not allow for accidental force quits.
(Reporter)

Updated

3 years ago
OS: Unspecified → Mac OS X
Summary: Surface warn before quitting for Mac users → Surface warn before quitting pref for Mac users
Component: General → Preferences
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 645338
You need to log in before you can comment on or make changes to this bug.