Can't minimise after changing themes



Core Graveyard
17 years ago
10 years ago


(Reporter: David G King, Assigned: Joe Hewitt (gone))


Windows 98

Firefox Tracking Flags

(Not tracked)





17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.7+) Gecko/20011220
BuildID:    2001122003

After changing Theme (View-ApplyTheme) the minimise button (top right of screen)
causes windows to quickly minimise and then restore. The Close button works.
Note: this happens when changing from Modern to Modern as well.

Reproducible: Always
Steps to Reproduce:
1. Open Mozilla
2. Change theme from View Menu
3. Select Apply Theme
4. Choose theme

Expected Results:  Expected Minimise to minimise the open window.

Comment 1

17 years ago
Just downloaded 0.9.7 (2001122106) and I notice that View-ApplyTheme has
reverted back to changing theme on restart.

As I don't fully understand the relationship between the Trunk (where I first
noticed the probem) and the Branch (where I just tested with 0.9.7) I can't
really comment on if this has been fixed or not.

Comment 2

17 years ago
I've just retested this using build 2001122703, and the problem is back again.

The first time I tried, Mozilla crashed (TB987360Q) but this may be related to
other activity that I did before I tried to change themes.

Comment 3

16 years ago
Just retested using build 2002010403, and the problem is still there.

However, subtle change in result. Before, when attempting to minimise a full
screen window, it would come back immediately as a full screen window. Now, it
comes back as a partial screen window.

Any progress in fixing this for good?


16 years ago
Component: Themes → Skinability

Comment 4

16 years ago

this bug sticks out in the bonsai query for the 12/19 into the 12-20 build.

I'll do some testing here with older builds I have to see if I see this too, or
if this when bug 120155 started, or maybe it was fixed, or wallpapered, and then
bug 120155 started in build 1/6.


Comment 5

16 years ago
I notice this is fixed. I'm not sure when that happened, but when I tested with
build 2002022203 it works fine.
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 6

16 years ago
wfm, also based on david's comment#5, this is fixed for him.

Comment 7

16 years ago
wfm, also based on david's comment#5, this is fixed for him.
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.