Sometimes parts of the File menu are grayed out

RESOLVED WORKSFORME

Status

()

Firefox
Menus
RESOLVED WORKSFORME
3 years ago
2 years ago

People

(Reporter: d_friedman, Unassigned)

Tracking

37 Branch
Unspecified
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:37.0) Gecko/20100101 Firefox/37.0
Build ID: 20150415140819

Steps to reproduce:

I am using Firefox 37.0.2 (and I think this happened in other recent previous versions as well). Sometimes when I click the File menu, the following items are grayed out:
Save Page as... , Email link..., Page Setup..., and Print... .  (I can't remember for sure, but I don't think Work Offline is grayed out.) This is very annoying, because it occurs when I am trying to save or print the page.  


Actual results:

As I said above, the lower parts of the File menu are grayed out, so that I am unable to save or print the page.

Oddly, sometimes eventually the file menu will be restored, such that items are not grayed out, and I can then save or print.  I cannot figure out what restores the file menu to operational status.  I have tried refreshing the page, switching to another tab and then back to the affected tab, and emptying the cache, but I am not sure what, if anything, works to make the file menu functional again, or if it's just random.  I cannot reproduce either the problem or the solution on demand.  If I figure out what make it happen, or what fixes it, I will post back.  Sorry, I don't happen to have a screen shot on hand.


Expected results:

The menu items should not have been grayed out.  So I should have been able to save or print the page.
Hi,

I have tested this on Mac OS X 10.6 and 10.10 with FF Nightly 46.0a1 and I can't reproduce you issue.
If you still have the problem please download the Firefox Nightly from here: https://nightly.mozilla.org/ and retest the problem. Also you can upgrade you release version to a newer one: https://www.mozilla.org/en-US/firefox/new/#
Flags: needinfo?(d_friedman)
(Reporter)

Comment 2

2 years ago
Hi -- I haven't seen this problem lately.  I'm now using 43.0.2; still using OS X 10.7.5.  Maybe it's not a problem anymore. Thanks!
Flags: needinfo?(d_friedman)

Comment 3

2 years ago
REOPEN this bug if it happened again.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Component: Untriaged → Menus
OS: Unspecified → Mac OS X
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.