Closed Bug 1164920 Opened 5 years ago Closed 5 years ago

Pocket button not disabled on first load in menu

Categories

(Firefox :: Pocket, defect, P4)

38 Branch
defect

Tracking

()

VERIFIED FIXED
Tracking Status
firefox38.0.5 --- wontfix
firefox41 --- fixed

People

(Reporter: sphilp, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: [fixed by bug 1164942])

On nightly 41.0a1 (2015-05-14)

Steps:

1. Move the pocket button to the hamburger menu by right-clicking the button and selecting "Move to Menu"

2. Force quit/restart nightly to load Firefox from a clean start up

3. Open the hamburger menu and click the pocket button

Actual:
The pocket button is enabled and will attempt to save the new tab page to pocket (loading spinner continuously spins so it seems like Pocket won't actually save it)

Expected:
The pocket button should be disabled/greyed out in the hamburger menu just like in the toolbar
Blocks: Pocket
This is specific to when the page currently loaded is non-savable (not http/https/reader-view), we don't seem to be disabling the button in this case... Perhaps the onLocationChange handler isn't hooked up early enough?
Priority: -- → P4
This bug should no longer occur now that bug 1164942 has been fixed.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Whiteboard: [fixed by bug 1164942]
This issue is still reproducible on Nightly 41.0a1 (2015-05-19), but in a slightly different way:
* After following the steps from Comment 0, the Pocket button from the menu ≡ is still NOT disabled.
* The first time you click the button, a panel will be displayed stating the "Page not saved. Only links can be saved."
* Clicking it again will display an unending "Saving..." message.

Testing was done using using Windows 7 (x64), Ubuntu 14.04 (x64) and Mac OS X 10.9.5 - here's a screenshot from Windows: http://i.imgur.com/hrSXEWd.png.

Also, looking through the comments from Bug 1164942, I noticed that Gijs requested an uplift for Beta, but I'm not quite sure if that stands for Beta 38.0.5 or Beta 39. Jared, could you please clarify? I think we need this on 38.0.5.
Flags: needinfo?(jaws)
Hi Andrei,

Can you file a bug about getting stuck on "Saving..."? Nate may be able to look in to that.

Yes, we should have bug 1164942 on 38.0.5 but it is now too late for that release. Getting it on 39 beta is needed though, or private browsing will have some weird behaviors because the button is supposed to remain disabled in private browsing (bug 1160407).
Flags: needinfo?(jaws)
(In reply to Jared Wein [:jaws] (please needinfo? me) from comment #4)
> Hi Andrei,
> 
> Can you file a bug about getting stuck on "Saving..."? Nate may be able to
> look in to that.
> 
> Yes, we should have bug 1164942 on 38.0.5 but it is now too late for that
> release. Getting it on 39 beta is needed though, or private browsing will
> have some weird behaviors because the button is supposed to remain disabled
> in private browsing (bug 1160407).

Filed Bug 1168351. Closing this one since we're tracking side-effects in separate bugs.
Blocks: 1168351
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.