Closed Bug 1164923 Opened 4 years ago Closed 4 years ago

Pocket Android app FxA sign in breaks after logging out

Categories

(Firefox :: Pocket, defect, P2)

38 Branch
defect

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: sphilp, Unassigned)

References

Details

Attachments

(1 file)

On an Alcatel One Touch device, logging into the Pocket Android add uses FxA works the first time, but if you log out and log back in the 'sign in' button no longer functions. Seems to be an issue on the FxA sign in view.

No error is shown on the view. Pocket has mentioned they could provide a debug build if we need one to try to reproduce this issue, if it can't be reproduce on a dev env.

It's possible this happens on other devices, but every other test device passed this test so it's hard to say what it was.

Here's a video demonstrating the issue https://www.youtube.com/watch?v=1snqyGaCpYQ
Blocks: Pocket
Cannot reproduce so far on One Plus One running Android 5.0.2 using the debug build "Pocket.b1.apk".
Cannot reproduce on "Google Nexus 4 - 4.3 API 18" simulator.
Using "Pocket.b2.apk". for those above as well....
Maybe an older android version? Of the devices tested, only the Alcatel One Touch (Android 4.1.2) had this issue. The others were 4.4+. Pocket won't support FxA on anything pre 4.x.
Works on the 4.1.1 Simulator. API level 16. Video https://www.dropbox.com/s/3v1nbjlnlknx17a/bugzilla1164923.mp4?dl=0
Darn, okay. Teo can you provide any further guidance here?
Flags: needinfo?(teodora.vermesan)
Attached file pocket-logs.txt
I've attached the logs while trying to reproduce the issue:
The steps are the following: 
-Log In -> Log In with Firefox -> "Sign in"
-Go to Settings and Log out
-Go once again to Log In -> Log In with Firefox
-Fill in the password (email is prefilled) and tap "Sign in"
Flags: needinfo?(teodora.vermesan)
Teodora, watching the youtube video posted in the first comment, it looks like the second time you log in, the password is almost twice as long as the first time. Should the final reproducing step be: "Fill in an invalid password (email is prefilled) and tap Sign in"?
Flags: needinfo?(teodora.vermesan)
(Sounds like this only breaks when trying to relogin within the same session, quitting and starting a new session apparently works, so at least this isn't a perma-fail.)

Bad UX, but also seems like this wouldn't affect too many users, just because I'd expect most people sign-in once and never sign out.
Priority: -- → P2
(In reply to Max from comment #8)
> Teodora, watching the youtube video posted in the first comment, it looks
> like the second time you log in, the password is almost twice as long as the
> first time. Should the final reproducing step be: "Fill in an invalid
> password (email is prefilled) and tap Sign in"?


Yes, if the password is wrong, the final step should be "Sign in to continue to Pocket" "Incorrect password" and if the password is correct, the user should be logged in.

But since there is no action when tapping the "Sign In" button, nothing happens.
Flags: needinfo?(teodora.vermesan)
Vlad can you confirm whether the "Incorrect password" message appears following the above steps?
Flags: needinfo?(vlad)
Both cases work for me: http://i.imgur.com/CCTKQm2.gif
On a 4.1.1 simulator
Flags: needinfo?(vlad)
Okay, since it seems to be difficult to reproduce to see what's going on, I'm closing this. If it comes up on another device we can try again.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.