Switch cypress to producing Win 8 builds

RESOLVED FIXED

Status

Release Engineering
General
RESOLVED FIXED
3 years ago
16 days ago

People

(Reporter: mossop, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

3 years ago
I'm using the cypress project branch, looks like it is only generating B2G builds right now. Can we switch it to only do Windows 8 builds, ideally with the same config as mozilla-aurora but that may not be important for my testing.
(Reporter)

Updated

3 years ago
Blocks: 1164006

Comment 1

3 years ago
Created attachment 8606014 [details] [diff] [review]
150414_1164935_reset_cypress_win864-bbot-cfgs.patch

this resets cypress to just win64 8 builders. To make these builders act like aurora (pgo as a per-checkin strategy), we need to tweak mozharness and pin cypress' mh rev

Comment 2

3 years ago
Comment on attachment 8606014 [details] [diff] [review]
150414_1164935_reset_cypress_win864-bbot-cfgs.patch

builderlist diff of my patch: http://people.mozilla.org/~jlund/reset_cypress_to_just_win864_builder_list.diff
Comment on attachment 8606014 [details] [diff] [review]
150414_1164935_reset_cypress_win864-bbot-cfgs.patch

lgtm
Attachment #8606014 - Flags: review+

Comment 4

3 years ago
Created attachment 8606019 [details] [diff] [review]
150414_1164935_cypress_to_be_per_checkin-mh.patch

per-checkin pgo strat, like most things for desktop builds, is controlled at the mozharness level. this will make it so every 'opt' build will actually be run with PGO enabled: http://mxr.mozilla.org/build/source/ash-mozharness/mozharness/mozilla/building/buildbase.py#801
Attachment #8606019 - Flags: review?(hwine)
Attachment #8606019 - Flags: review?(hwine) → review+

Comment 5

3 years ago
Created attachment 8606034 [details] [diff] [review]
150414_1164935_reset_cypress_win864_add_debug-bbot-cfgs.patch

looks like travis is complaining about a stray debug test. I guess we need the debug builder coupled with the opt one.
Comment on attachment 8606034 [details] [diff] [review]
150414_1164935_reset_cypress_win864_add_debug-bbot-cfgs.patch

shoot, we don't need debug, everyone here is perfect!
Attachment #8606034 - Flags: review+

Comment 9

3 years ago
mozharness production tag moved to: https://hg.mozilla.org/build/mozharness/rev/production
leaving open but to verify but this work should be done. further instructions sent to mossop over irc
QA Contact: catlee → jlund
(Reporter)

Comment 11

3 years ago
This looks good, cypress is reproducing the failure from bug 1164006
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Assignee)

Updated

16 days ago
Component: General Automation → General
Product: Release Engineering → Release Engineering
You need to log in before you can comment on or make changes to this bug.