Music playback is getting stopped and is not resumed when modem is restarted

RESOLVED FIXED in Firefox 41

Status

defect
RESOLVED FIXED
4 years ago
6 months ago

People

(Reporter: diego, Assigned: diego)

Tracking

unspecified
mozilla41
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, firefox39 wontfix, firefox40 wontfix, firefox41 fixed, b2g-v2.2 fixed, b2g-master fixed)

Details

(Whiteboard: [caf priority: p2][CR 834802])

Attachments

(1 attachment)

(Assignee)

Description

4 years ago
This is happening on a Lollipop prototype being used by CAF. When the modem is restarted on this device the audio media framework gets hosed and no more audio clips can be played until the phone is restarted.

The reason is that in this device the gonk system process attempts to update audio settings. However, we currently only allow the radio and bluetooth processes to update audio settings [1]. This is easily fixed by granting audio settings permission to the system process too (AID_SYSTEM).

[1] https://mxr.mozilla.org/mozilla-central/source/widget/gonk/GonkPermission.cpp#123
(Assignee)

Updated

4 years ago
blocking-b2g: --- → 2.2?
Whiteboard: [CR 834802]
Whiteboard: [CR 834802] → [caf priority: p2][CR 834802]
Hsin-Yi, are you ok with Diego's suggestion to grant audio settings permission to System?
Flags: needinfo?(htsai)
(In reply to Dylan Oliver [:doliver] from comment #1)
> Hsin-Yi, are you ok with Diego's suggestion to grant audio settings
> permission to System?

It looks fine to me, but Michael seems the right reviewer.
Flags: needinfo?(htsai) → needinfo?(mwu)
Steven, what do you think for this?
Flags: needinfo?(slee)

Comment 4

4 years ago
(In reply to Ken Chang[:ken] from comment #3)
> Steven, what do you think for this?

I think it's OK, but we need mwu's approval.
Flags: needinfo?(slee)
(Assignee)

Comment 5

4 years ago
Flags: needinfo?(mwu)
Attachment #8607716 - Flags: review?(mwu)
(Assignee)

Updated

4 years ago
Assignee: nobody → dwilson
Status: NEW → ASSIGNED

Updated

4 years ago
Attachment #8607716 - Flags: review?(mwu) → review+
(Assignee)

Comment 8

4 years ago
Comment on attachment 8607716 [details] [diff] [review]
Add permission to modify audio settings to system process

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Bug caused by (feature/regressing bug #):
Bug 976839

User impact if declined:
Bluetooth will not recover gracefully after a bluetooth subsystem crash.

Testing completed:
Force crashed the bluetooth subsystem on Flame Kitkat and a Lollipop prototype device. My bluetooth headset reconnected correctly.

Risk to taking this patch (and alternatives if risky): 
There are no obvious risks I can identify.

String or UUID changes made by this patch:
None
Attachment #8607716 - Flags: approval-mozilla-b2g37?
https://hg.mozilla.org/mozilla-central/rev/c92eb84dfd39
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla41

Updated

4 years ago
blocking-b2g: 2.2? → 2.2+

Updated

4 years ago
Attachment #8607716 - Flags: approval-mozilla-b2g37? → approval-mozilla-b2g37+

Updated

6 months ago
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.