bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Cannot unblock images - Firefox permissions.sqlite file not working properly

RESOLVED WORKSFORME

Status

()

Core
Permission Manager
RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: FredMcD, Unassigned)

Tracking

37 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:37.0) Gecko/20100101 Firefox/37.0
Build ID: 20150415140819

Steps to reproduce:

At a web site, I wanted to stop one image from that web site. I used "Page Info > Media." I found that image, and turned on the "Block" for that image. But blocking that image caused all images to be blocked. So I went back and unblocked the image.


Actual results:

But the setting refused to stay unblocked. I checked the help articles, and they said; "in the Options Menu, go to Content, and allow images from there." But there are no image settings on this, or any other options page. This information came from several help pages.

Do those help pages need to be updated? And where are the image controls?

After, I started poking around the user profile. I found that web site listed in the permissions.sqlite file. Once I edited the website entry, the block was gone. Later, I deleted permissions.sqlite because of other issues caming up. Now running without those issues.


Expected results:

I should have been able to remove the block. I have done so in the past without issues.
Comment hidden (off-topic)

Updated

3 years ago
Component: Untriaged → Preferences
Version: 37 Branch → 42 Branch
Comment hidden (off-topic)

Comment 3

3 years ago
(In reply to FredMcD from comment #0)
> At a web site, I wanted to stop one image from that web site. I used "Page
> Info > Media." I found that image, and turned on the "Block" for that image.
> But blocking that image caused all images to be blocked. So I went back and
> unblocked the image.

Firefox has never had an option to block individual images. The setting is clearly labeled,
“Block images from example.com”.

> I checked the help articles, and they said; "in the Options Menu, go to Content,
> and allow images from there." But there are no image settings on this, or any
> other options page. This information came from several help pages. Do those
> help pages need to be updated?

See bug 851701 and bug 514739.
Impossible to say without a link to the articles in question. The current article for
Options / Preferences → Content explains that the image option was removed:
https://support.mozilla.org/kb/settings-for-web-content-pop-ups-fonts-languages

> And where are the image controls?

1. Right-click an empty area of the page and choose “View Page Info”.
2. Click the Permissions icon.
3. Change the setting for “Load images”.

> Now running without those issues.

Resolved, non-reproducible issue filed for Firefox 37 → WORKSFORME.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Component: Preferences → Permission Manager
Product: Firefox → Core
Resolution: --- → WORKSFORME
Summary: Firefox permissions.sqlite file not working properly > options → Cannot unblock images - Firefox permissions.sqlite file not working properly
Version: 42 Branch → 37 Branch
You need to log in before you can comment on or make changes to this bug.