Closed Bug 1165160 Opened 7 years ago Closed 7 years ago

[Stingray] Marionette sendKeys method fails at dashboard app test

Categories

(Firefox OS Graveyard :: Gaia::TV, defect)

x86
macOS
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: yifan, Assigned: johnhu)

References

Details

(Whiteboard: [ft:conndevices])

Attachments

(1 file)

When running dashboard marionette test, the sendKeys method fails due to focus issue.
The root cause of this issue is that: we tries to send the keyevent too early before smart-system booted. Smart System has a mechanism to prevent unexpected keyboard behaviors. It blocks all keyboard events if the focus is wrong. The system is viewed as crashed if the focus is wrong. During the booting procedure, we may create a lot of UI and iframe. The focus is moved from booting logo to iframe once fully booted.

So, if a keyboard event is sent to an iframe too early, it is blocked.

This feature is done for partner but not picked. So, I will turn it off by default but partner can turn it on through settings key, focusmanager.autofix.enabled.
Comment on attachment 8606067 [details] [review]
[gaia] huchengtw-moz:bug-1165160-turn-off-fallback-by-default > mozilla-b2g:master

Please review this patch. The default behavior is to turn off the catcher. But we can still turn it on through settings key.
Attachment #8606067 - Flags: review?(chens)
Attachment #8606067 - Flags: feedback?(yliao)
Comment on attachment 8606067 [details] [review]
[gaia] huchengtw-moz:bug-1165160-turn-off-fallback-by-default > mozilla-b2g:master

Test for dashboard passes. Thanks!
Attachment #8606067 - Flags: feedback?(yliao) → feedback+
Comment on attachment 8606067 [details] [review]
[gaia] huchengtw-moz:bug-1165160-turn-off-fallback-by-default > mozilla-b2g:master

looks good to me
Attachment #8606067 - Flags: review?(chens) → review+
http://docs.taskcluster.net/tools/task-graph-inspector/#2-Z9D8zRRvKrxXkK9Fbhig

The pull request failed to pass integration tests. It could not be landed, please try again.
https://github.com/mozilla-b2g/gaia/pull/30074

Autolander could not land the pull request due to not having collaborator rights. This is possibly due to a tree closure. Please check the tree status and request checkin again once the tree is open.
https://github.com/mozilla-b2g/gaia/pull/30074

Autolander could not land the pull request due to not having collaborator rights. This is possibly due to a tree closure. Please check the tree status and request checkin again once the tree is open.
https://github.com/mozilla-b2g/gaia/pull/30074

Autolander could not land the pull request due to not having collaborator rights. This is possibly due to a tree closure. Please check the tree status and request checkin again once the tree is open.
Trying again due to tree closures. Sorry about the spam here.
Keywords: checkin-needed
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.