Enabling Ruler from the toolbox button doesn't do anything, produces error

RESOLVED DUPLICATE of bug 1164887

Status

()

Firefox
Developer Tools: Inspector
RESOLVED DUPLICATE of bug 1164887
3 years ago
3 years ago

People

(Reporter: canuckistani, Assigned: zer0)

Tracking

41 Branch
Points:
---

Firefox Tracking Flags

(firefox41 affected)

Details

STR:

1. in settings, enable the toolbox button
2. click on the toolbox button to enable rules

Expected: rulers!

Actual:

21:33:35.073 <unavailable> cli.js:2044
21:33:35.076 Object { isTypedData: true, data: Object, type: "error" } cli.js:2044

resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/devtools/server/actors/gcli.js: 256
"environment.chromeWindow is not available in runAt:server commands"

"GcliActor<._getRequisition/this._requisitionPromise</environment.chromeWindow@resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/devtools/server/actors/gcli.js:256:17exports.items<.exec@resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/devtools/gcli/commands/rulers.js:59:9Requisition.prototype.exec/<@resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/devtools/gcli/cli.js:2073:16createAsyncFunction/asyncFunction@resource://gre/modules/Task.jsm:239:18Task_spawn@resource://gre/modules/Task.jsm:164:12exports.exec@resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/devtools/gcli/util/host.js:72:10Requisition.prototype.exec@resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/devtools/gcli/cli.js:2072:14Requisition.prototype.updateExec/<@resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/devtools/gcli/cli.js:2112:12Handler.prototype.process@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:867:23this.PromiseWalker.walkerLoop@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:746:7this.PromiseWalker.scheduleWalkerLoop/<@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:688:37Promise*this.PromiseWalker.scheduleWalkerLoop@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:688:5this.PromiseWalker.schedulePromise@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:709:7Promise.prototype.then@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:417:5GcliActor<.execute<@resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/devtools/server/actors/gcli.js:116:12actorProto/</handler@resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/devtools/server/protocol.js:1006:19DSC_onPacket@resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/devtools/server/main.js:1456:15ChildDebuggerTransport.prototype.receiveMessage@resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/devtools/transport/transport.js:734:5"
This happens either in e10s or not, and in tonight's Nightly 41 and current Dev Edition 40 builds.
Thanks for raising this Jeff, I think it's a dupe of bug 1164887.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1164887
You need to log in before you can comment on or make changes to this bug.