[RTL][Email]The title in Google login page is truncated at left side.

VERIFIED FIXED in 2.2 S13 (29may)

Status

defect
P2
normal
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: lulu.tian, Assigned: jrburke)

Tracking

unspecified
2.2 S13 (29may)
ARM
Gonk (Firefox OS)
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [2.2-nexus-5-l])

Attachments

(4 attachments)

(Reporter)

Description

4 years ago
[1.Description]:
[RTL][Flame v2.2&v3.0][Nexus 5 2.2&3.0][Email]The title with long LTR text in Google login page is truncated at left side.
See attachment:Google login page.png

[2.Testing Steps]: 
Prerequisite: There is no email account logged in.
1. Set system language as Arabic.
2. Launch Email.
3. Input a name and Google address and then tap next button.
4. Observe the Google login page.
5. Input a valid password and tap "Sign in" button.
6. Observe the view.

[3.Expected Result]: 
4&6. The title in Google login page should be truncated at right side of long LTR text.

[4.Actual Result]: 
4&6. The title in Google login page is truncated at left side.

[5.Reproduction build]: 
Device: Flame 2.2 (affected)
Build ID               20150514002501
Gaia Revision          aac58a063e3e6acae6ba77fe4cec224fb69450bc
Gaia Date              2015-05-13 12:59:48
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/47f1ced9f1d6
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150514.040500
Firmware Date          Thu May 14 04:05:11 EDT 2015
Bootloader             L1TC000118D0

Device: Flame 3.0 (affected)
Build ID               20150514131323
Gaia Revision          338f66e6a96491d2f5854b188c6b141ceb690d97
Gaia Date              2015-05-13 14:08:45
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/633684c4ebc4
Gecko Version          41.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150514.165247
Firmware Date          Thu May 14 16:53:00 EDT 2015
Bootloader             L1TC000118D0

Device: Nexus 5 2.2 (affected)
Build ID               20150514002501
Gaia Revision          aac58a063e3e6acae6ba77fe4cec224fb69450bc
Gaia Date              2015-05-13 12:59:48
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/47f1ced9f1d6
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150514.033743
Firmware Date          Thu May 14 03:37:59 EDT 2015
Bootloader             HHZ12f

Device: Nexus 5 3.0 (affected)
Build ID               20150514010203
Gaia Revision          338f66e6a96491d2f5854b188c6b141ceb690d97
Gaia Date              2015-05-13 14:08:45
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/1fab94ad196c
Gecko Version          41.0a1
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150514.044222
Firmware Date          Thu May 14 04:42:38 EDT 2015
Bootloader             HHZ12f

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
(Reporter)

Updated

4 years ago
QA Whiteboard: [rtl-impact]
Triage: P2
Priority: -- → P2
I know it says email, Sam, would you mind looking?  You've already handled similar issues with the URL in other places.
Flags: needinfo?(sfoster)
fyi, delphine.
blocking-b2g: --- → 2.2?
Flags: needinfo?(lebedel.delphine)
(In reply to Naoki Hirata :nhirata (please use needinfo instead of cc) from comment #2)
> I know it says email, Sam, would you mind looking?  You've already handled
> similar issues with the URL in other places.

I think is might be best if the email folks look at this one. It *looks* similar, and ultimately it will need the same kind of fix as bug 1155459, bug 1157610, bug 1151925 etc. But I'm not familiar with the email cards and how/where these headers are managed and updated. It seems like we might be able to simply do something like: 

--- a/apps/email/js/cards/setup_account_info.html
+++ b/apps/email/js/cards/setup_account_info.html
@@ -8,8 +8,8 @@
        role="button" data-l10n-id="back-button">
       <span class="icon icon-back"></span>
     </a>
-    <h1 class="sup-account-header-label"
-        data-l10n-id="setup-account-header3"></h1>
+    <h1><bdi dir="auto" class="sup-account-header-label"
+        data-l10n-id="setup-account-header3"></bdi></h1>
   </header>

.. on each of those card documents. But I didn't trace through the JS and CSS to see if that might cause complications with the font-sizing and other operations going on in there. I'm forwarding the ni onto James.
Flags: needinfo?(sfoster) → needinfo?(jrburke)
Flags: needinfo?(lebedel.delphine)
(Assignee)

Comment 6

4 years ago
Comment on attachment 8606590 [details] [review]
[gaia] jrburke:bug1165205-email-browser-url > mozilla-b2g:master

We just forgot to put the dir="auto" for that header. This pull request fixes the issue, now the https:// google domain is shown instead of showing the end of the string.
Flags: needinfo?(jrburke)
Attachment #8606590 - Flags: review?(bugmail)
Attachment #8606590 - Flags: review?(bugmail) → review+
(Assignee)

Updated

4 years ago
Keywords: checkin-needed
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Assignee)

Comment 8

4 years ago
Comment on attachment 8606590 [details] [review]
[gaia] jrburke:bug1165205-email-browser-url > mozilla-b2g:master

[Approval Request Comment]

[Bug caused by] (feature/regressing bug #):
Missed the dir="auto" for this element in initial RTL work.

[User impact] if declined:
User will not see the domain/scheme of the URL when logging in to google in the oauth jump. For security reasons it is preferable for the domain and scheme to be shown, to give the user an indication which domain the user is on.

[Testing completed]:
On flame device with ltr and rtl UI going through the oauth flow.

[Risk to taking this patch] (and alternatives if risky):
Super low. Just an extra dir="auto" on one HTML tag.

[String changes made]:
none
Attachment #8606590 - Flags: approval-gaia-v2.2?

Updated

4 years ago
blocking-b2g: 2.2? → 2.2+

Updated

4 years ago
Attachment #8606590 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+

Updated

4 years ago
Keywords: verifyme
(Reporter)

Comment 9

4 years ago
This issue has been verified as pass on latest build of Flame 3.0 and Nexus 5 3.0 by the STRs in comment 0.
Result: The title of Google login page with long LTR text is truncated at right side.
See attachment:Google login page verify_pass.png
Rate:0/5

Device: Flame 3.0 (pass)
Build ID               20150517160201
Gaia Revision          afea16de7a76c3b6d15c35fb4c37bac71c8ddc6a
Gaia Date              2015-05-17 03:33:40
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/35918b0441b4
Gecko Version          41.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150517.212430
Firmware Date          Sun May 17 21:24:42 EDT 2015
Bootloader             L1TC000118D0

Device: Nexus 5 3.0 (pass)
Build ID               20150517160201
Gaia Revision          afea16de7a76c3b6d15c35fb4c37bac71c8ddc6a
Gaia Date              2015-05-17 03:33:40
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/35918b0441b4
Gecko Version          41.0a1
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150517.194053
Firmware Date          Sun May 17 19:41:09 EDT 2015
Bootloader             HHZ12f
(Reporter)

Updated

4 years ago
QA Whiteboard: [rtl-impact] → [rtl-impact][MGSEI-Triage+]
Keywords: verifyme
See Also: → 1165829
v2.2: https://github.com/mozilla-b2g/gaia/commit/273d6e7d4c01db9fb55d19b5ed9dc4fc435314e5
Assignee: nobody → jrburke
Target Milestone: --- → 2.2 S13 (29may)
(Reporter)

Comment 11

4 years ago
Posted image verify_v2.2_pass.png
This issue has been verified as pass on latest build of Flame 2.2 and Nexus 5 2.2 by the STRs in comment 0.
Result: The title of Google login page with long LTR text is truncated at right side.
See attachment:verify_v2.2_pass.png
Rate:0/5

Device: Flame 2.2 (pass)
Build ID               20150519162501
Gaia Revision          63e9eeec3032318f8a240f80b6a184fa4b50b6e1
Gaia Date              2015-05-19 17:52:15
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/4e078e1364d3
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150519.200807
Firmware Date          Tue May 19 20:08:18 EDT 2015
Bootloader             L1TC000118D0

Device: Nexus 5 2.2 (pass)
Build ID               20150519162501
Gaia Revision          63e9eeec3032318f8a240f80b6a184fa4b50b6e1
Gaia Date              2015-05-19 17:52:15
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/4e078e1364d3
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150519.195445
Firmware Date          Tue May 19 19:55:01 EDT 2015
Bootloader             HHZ12f
(Reporter)

Updated

4 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 12

4 years ago
Test case has been added in moztrap:
https://moztrap.mozilla.org/manage/case/15279/
Flags: in-moztrap+
You need to log in before you can comment on or make changes to this bug.