[Settings]The heading at "Enter certificate nick name" view is truncated.

VERIFIED DUPLICATE of bug 1161364

Status

defect
VERIFIED DUPLICATE of bug 1161364
4 years ago
4 years ago

People

(Reporter: yue.xia, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.2 verified)

Details

(Whiteboard: LocRun2.2)

Attachments

(5 attachments)

(Reporter)

Description

4 years ago
[1.Description]:
[Settings][Flame 2.2]Import Wi-Fi certificate and select a certificates file to enter, the heading at "Enter certificate nick name" view is truncated.
See attachment:
Spanish_Enter certificate nick name.png
Bengali India_Enter certificate nick name.png
Arabic_Enter certificate nick name.png
cacert.crt

[2.Testing Steps]: 
Precondition:Set system language as Basque and there're Wi-Fi certificates file in device storage.
1.Launch Settings app
2.Enter "Wi-Fi" view.
3.Tap "Manage Certificates"
4.Tap "Import Certificate" and select a certificates file.

[3.Expected Result]: 
4. The heading at "Enter certificate nick name" view should not be truncated.

[4.Actual Result]: 
4. The heading at "Enter certificate nick name" view is truncated.

[5.Reproduction build]: 
Device: Flame 2.1 user (Unaffected)
Build ID               20150514001201
Gaia Revision          c80865cb0bf73f1b97defbc646083b404feb3ac4
Gaia Date              2015-05-12 06:26:43
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/23eb9df75991
Gecko Version          34.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150514.035617
Firmware Date          Thu May 14 03:56:27 EDT 2015
Bootloader             L1TC000118D0

Device: Flame 2.2 user (Affected)
Build ID               20150514002501
Gaia Revision          aac58a063e3e6acae6ba77fe4cec224fb69450bc
Gaia Date              2015-05-13 12:59:48
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/47f1ced9f1d6
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150514.040432
Firmware Date          Thu May 14 04:04:43 EDT 2015
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test

[8.Note]:
* This problem can be reproduced in Spanish, Bengali from India, Arabic, Serbian Cyrillic, Russian, Greek, Basque, Portuguese from Brazil, Portuguese from Portugal language, and the issue in Serbian Cyrillic, Russian, Greek, Basque, Portuguese from Brazil, Portuguese from Portugal should be submited under Mozilla localizaller.
* This issue does not exist in Polish
(Reporter)

Comment 3

4 years ago
Posted file cacert.crt
Posted image en_header.jpg
While working on bug 1165232 I noticed that en 2.2 version is also truncated.

Reducing font size of header should fix most truncations in other locales.
Blocks: 1165232
Regression, blocking 2.2 on this.
blocking-b2g: --- → 2.2+
Keywords: regression
Dupe of bug 1161364? Cause is the header font-size change? Looking at the 2.1 vs. 2.2 screenshots seems to confirm this.
Aha correct, thanks Sam! We should maybe change the title of that other bug to reflect that it concerns header font-size change, not just that single string. 
Closing this bug as resolved dupe
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1161364
Hey Sam: looking in deeper and talking with Vanja, I want to double check something with you: will the fix in bug 1161364 cover both these header strings in Settings - or just that one string mentioned in bug 1161364?

I say that because here the string is "Enter certificate nick name" and the other bug's string is different and not in the same area: "Select certificate file". So we want to be extra sure that bug 1161364 will really cover both fixes. thanks!
Flags: needinfo?(sfoster)
(from what I understand, it will fix all headers in settings, but prefer to edge on the safe side and get confirmation :) )
hi Delphine, I changed the bug title and added a comment on bug 1161364 to clarify. Yes, these are effectively the same problem, and as we seem to have consensus that the strings can't change to accomodate the larger minumum font-size, the code must. And the fix for one, will fix the other. The <gaia-header> component is used throughout the gaia app; I would be very surprised if these were the only 2 instances of this bug.
Flags: needinfo?(sfoster)
Ok thanks for clarifying Sam! Since you confirm this is used throughout the gaia app, these will definitely not be the only 2 instances. There will be a LOT. thanks!!
Please verify once Bug 1161364 fix lands on 2.2. thanks!
Keywords: verifyme
(Reporter)

Comment 13

4 years ago
Hi Delphine,
Because bug 1161364 has been fixed and verified as pass on 2.2. This Problem also can be reproduced on latest user build of Flame 2.2 in Spanish, Bengali India and Arabic languages. Could you please help with it?
Many thanks!

Device information:
Flame 2.2 User Build ID: 20150604002503
Flags: needinfo?(lebedel.delphine)
Please open up separate bugs under Mozilla LOcalizations for the remaining locales that are affected, so we can see individually if the localizers can help find a solution. Also, please mention each time that although bug 1161364 landed, these locales are still affected. thanks!
Flags: needinfo?(lebedel.delphine) → needinfo?(yue.xia)
(Reporter)

Updated

4 years ago
See Also: → 1173269
(Reporter)

Updated

4 years ago
See Also: → 1173271
(Reporter)

Updated

4 years ago
See Also: → 1173275
(Reporter)

Comment 15

4 years ago
Hi Delphine,
I have submitted 3 new bugs in Mozilla Localizations for tracking the remaining locales (Spanish, Bengali India and Arabic) that are affected on Flame 2.2. please see bug 1173269, 1173271 and 1173275.
Many thanks!
Flags: needinfo?(yue.xia)
(Reporter)

Updated

4 years ago
QA Whiteboard: [MGSEI-l10n-1F]
Keywords: verifyme
Whiteboard: LocRun2.2, MGSEI-l10n-1F → LocRun2.2
(Reporter)

Updated

4 years ago
QA Whiteboard: [MGSEI-l10n-1F] → [MGSEI-l10n-1F][MGSEI-Triage+]
bug 1173269, bug 1173271 and bug 1173275 are resolved and verified, so close this issue.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.