Closed Bug 1165261 Opened 6 years ago Closed 6 years ago

[D2D1.1] Input fields stay invisible until focusing/hovering on them

Categories

(Core :: Graphics: Layers, defect)

38 Branch
x86_64
Windows 8.1
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1160070

People

(Reporter: vavooon, Unassigned)

Details

Attachments

(3 files)

Attached image Invisible input field
User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:38.0) Gecko/20100101 Firefox/38.0
Build ID: 20150513174244

Steps to reproduce:

It happens for me at some sites, for example at http://forum.smplayer.info/ucp.php?mode=login .

It think it happens on PCs with Intel Graphics 2000.
There are also errors at about:support page in graphics section:
(#0) Error	[D2D1.1] 4CreateBitmap failure Size(26,8284) Code: 0x80070057
(#1) Error	[D2D1.1] 4CreateBitmap failure Size(26,8284) Code: 0x80070057.


Actual results:

Input fields stay invisible until i focus/hover on them.


Expected results:

Input fields should be displayed at once.
Attached image Same field after hover
OS: Unspecified → Windows 7
Hardware: Unspecified → x86_64
OS: Windows 7 → Windows 8.1
BTW i use latest drivers.
Attached image Another case
It seems the issue happens not only to inputs.
There is no one song in the list.
Could you type about:support and paste here the section "graphics".

Did you test with a fresh profile? Same issue?
https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles
Flags: needinfo?(vavooon)
Sure, here it is:

Графіка
Апаратно прискорені вікна	1/1 Direct3D 11 (OMTC)
Версія драйвера	9.17.10.4101
Дата драйвера	1-30-2015
Драйвери відеоплати	igdumd64 igd10umd64 igd10umd64 igdumd32 igd10umd32 igd10umd32
Код виробника	0x8086
Код підсистеми	21111462
Код пристрою	0x0102
Опис відеоплати	Intel(R) HD Graphics
Пам’ять відеоплати	Unknown
Рендерер WebGL	Google Inc. -- ANGLE (Intel(R) HD Graphics Direct3D9Ex vs_3_0 ps_3_0)
Direct2D увімкнено	true
DirectWrite увімкнено	true (6.3.9600.17795)
GPU #2 активний	false
windowLayerManagerRemote	true
AzureCanvasBackend	direct2d 1.1
AzureContentBackend	direct2d 1.1
AzureFallbackCanvasBackend	cairo
AzureSkiaAccelerated	0
(#0) Error	[D2D1.1] 4CreateBitmap failure Size(26,8284) Code: 0x80070057
(#7) Error	[D2D1.1] 4CreateBitmap failure Size(198,12647) Code: 0x80070057
(#8) Error	[D2D1.1] 4CreateBitmap failure Size(26,8284) Code: 0x80070057
(#9) Error	[D2D1.1] 4CreateBitmap failure Size(26,8284) Code: 0x80070057
(#10) Error	[D2D1.1] 4CreateBitmap failure Size(26,8284) Code: 0x80070057
(#11) Error	[D2D1.1] 4CreateBitmap failure Size(26,8284) Code: 0x80070057

Yes, i tried it with fresh profile in Nigtly and got the issue again.
Flags: needinfo?(vavooon)
Component: Untriaged → Graphics: Layers
Product: Firefox → Core
Summary: Input fields rendering issues → Input fields stay invisible until focusing/hovering on them
Can you reproduce the issue if you do the following?

1. Paste the following into the location bar, then press Enter.
about:config?filter=direct2d
2. Click the “I'll be careful, I promise!” button to bypass the warning.
3. Double-click gfx.direct2d.use1_1 to set its value to false
4. Double-click gfx.content.azure.backends and set its value to direct2d,cairo
5. Double-click gfx.canvas.azure.backends and set its value to direct2d,cairo
6. Restart Firefox.
Flags: needinfo?(vavooon)
Great, all works as expected.
Let me few hours to make sure that the problem is gone.
Flags: needinfo?(vavooon)
Well, i checked pages which caused the bug and it doesn't appear anymore.
Thank you for the update. To return the aforementioned preferences to their defaults, you can right-click each one and choose Reset.

Marking as a duplicate because
* It involves an input element.
* It involves Intel graphics.
* The issue goes away when performing the troubleshooting steps at bug 1160070, comment 7.
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Summary: Input fields stay invisible until focusing/hovering on them → [D2D1.1] Input fields stay invisible until focusing/hovering on them
Duplicate of bug: 1160070
You need to log in before you can comment on or make changes to this bug.