Closed Bug 1165284 Opened 8 years ago Closed 7 years ago

DevEdition theme is buggy on Windows XP

Categories

(Firefox :: Theme, defect)

40 Branch
x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox39 --- unaffected
firefox40 --- affected
firefox41 --- affected

People

(Reporter: ntim, Unassigned)

References

Details

Attachments

(1 file)

Issues :
- Window background is transparent when window is unmaximized
- Toggling the devedition theme for the first time makes the whole window disappear
See Also: → 1164952
I'm thinking that the fix from Bug 1164952 will fix this too

(In reply to Tim Nguyen [:ntim] (limited availability) from comment #0)
> - Toggling the devedition theme for the first time makes the whole window
> disappear

The entire application?  Does it become visible again after refocusing and/or restarting?
(In reply to Brian Grinstead [:bgrins] from comment #1)
> I'm thinking that the fix from Bug 1164952 will fix this too
> 
> (In reply to Tim Nguyen [:ntim] (limited availability) from comment #0)
> > - Toggling the devedition theme for the first time makes the whole window
> > disappear
> 
> The entire application?  Does it become visible again after refocusing
> and/or restarting?

The entire app disappears and becomes visible again after restarting.
(In reply to Tim Nguyen [:ntim] (limited availability) from comment #2)
> (In reply to Brian Grinstead [:bgrins] from comment #1)
> > I'm thinking that the fix from Bug 1164952 will fix this too
> > 
> > (In reply to Tim Nguyen [:ntim] (limited availability) from comment #0)
> > > - Toggling the devedition theme for the first time makes the whole window
> > > disappear
> > 
> > The entire application?  Does it become visible again after refocusing
> > and/or restarting?
> 
> The entire app disappears and becomes visible again after restarting.

Can you tell if this happens on first startup with a clean profile for a dev edition build like http://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/mozilla-aurora-win32/1431416426/?
Also, can you upload a screenshot?
(In reply to Brian Grinstead [:bgrins] from comment #4)
> Also, can you upload a screenshot?
Will test Monday on my school computers (I don't have XP at home).
Attached image screenshot
I can reproduce on Windows7 Classic

Str
1. Start Aurora40.0a1
   --- Toolbox and titlebar transparent(Bug 1164952)
2. Press F11 to Maximized
3. Press F11 to back to normal

Actual Results:
border (left/right/bottom) only, UI and contents completely transparent
Version: unspecified → 40 Branch
I reproduced the XP bug on Firefox 41.
I have an ongoing try push for Bug 1164952, I'm curious if it will fix these issues: https://treeherder.mozilla.org/#/jobs?repo=try&revision=ad8b9daf94b8
(In reply to Brian Grinstead [:bgrins] from comment #8)
> I have an ongoing try push for Bug 1164952, I'm curious if it will fix these
> issues: https://treeherder.mozilla.org/#/jobs?repo=try&revision=ad8b9daf94b8

Can you please let me know if this build fixes these issues on XP?
Flags: needinfo?(alice0775)
(In reply to Brian Grinstead [:bgrins] from comment #9)
> (In reply to Brian Grinstead [:bgrins] from comment #8)
> > I have an ongoing try push for Bug 1164952, I'm curious if it will fix these
> > issues: https://treeherder.mozilla.org/#/jobs?repo=try&revision=ad8b9daf94b8
> 
> Can you please let me know if this build fixes these issues on XP?

I am not able to test, because the try-build is not aurora base(dev).
Flags: needinfo?(alice0775)
Depends on: 1164952
See Also: 1164952
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.