If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Every version since 36.0.4 crashes on Linux 32 bit

RESOLVED WORKSFORME

Status

()

Firefox
Tabbed Browser
--
critical
RESOLVED WORKSFORME
3 years ago
2 years ago

People

(Reporter: Ulrich Teichert, Unassigned)

Tracking

({crash, regression})

37 Branch
x86
Linux
crash, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Linux i686; rv:36.0) Gecko/20100101 Firefox/36.0
Build ID: 20150320202338

Steps to reproduce:

Open up 4-6 pages in parallel on different tabs, switch back to one opened at the begining which is not fully opened, switch to another tabs and so on. As long as pages aren't fully loaded and displayed, this leads to a crash.


Actual results:

The crash reporter simply states that the application did not leave a trace and is unable to report the error.

Happens since 37, tried 37.0.x and 38, same behaviour on Linux 32bit, Debian 7.8, kernel 3.2. Versions until 36.0.4 are running fine.


Expected results:

It should not crash...
(Reporter)

Comment 1

3 years ago
Please contact me if I can help you further, like providing a backtrace or something if you can't reproduce the problem. To me it seems like these crashes are restricted to 32 bit versions only.
(Reporter)

Updated

3 years ago
OS: Unspecified → Linux
Hardware: Unspecified → x86
(Reporter)

Comment 2

3 years ago
Just tried 38.0.1, same crash. Deleteing TABs while loading seems to aggravate the issue.
Version: 37 Branch → 38 Branch
(Reporter)

Comment 3

3 years ago
These were the last bits written on the terminal before the crash:

###!!! [Parent][MessageChannel] Error: Channel error: cannot send/recv

WARNING: content window passed to PrivateBrowsingUtils.isWindowPrivate. Use isContentWindowPrivate instead (but only for frame scripts).
pbu_isWindowPrivate@resource://gre/modules/PrivateBrowsingUtils.jsm:25:14
nsBrowserAccess.prototype.openURI@chrome://browser/content/browser.js:15192:21
M@http://cdn.engine.4dsply.com/Scripts/infinity.js.aspx?guid=3e5e4525-c659-46d8-a414-c7a252cefed1:1:25580
N@http://cdn.engine.4dsply.com/Scripts/infinity.js.aspx?guid=3e5e4525-c659-46d8-a414-c7a252cefed1:1:24922
i/Z/al@http://cdn.engine.4dsply.com/Scripts/infinity.js.aspx?guid=3e5e4525-c659-46d8-a414-c7a252cefed1:1:23724
i/Z@http://cdn.engine.4dsply.com/Scripts/infinity.js.aspx?guid=3e5e4525-c659-46d8-a414-c7a252cefed1:1:24763
g367CB268B1094004A3689751E7AC568F.BindOnDocmentClick/<@http://cdn.engine.4dsply.com/Scripts/infinity.js.aspx?guid=3e5e4525-c659-46d8-a414-c7a252cefed1:1:33386
g.event.Xm@http://sic-akamai.33across.com/1/javascripts/sic.js:68:489
n@http://sic-akamai.33across.com/1/javascripts/sic.js:174:31
_adjustFocusAfterTabSwitch@chrome://browser/content/tabbrowser.xml:1273:9
updateCurrentBrowser@chrome://browser/content/tabbrowser.xml:1198:17
onselect@chrome://browser/content/browser.xul:1:44
set_selectedIndex@chrome://global/content/bindings/tabbox.xml:666:13
set_selectedPanel@chrome://global/content/bindings/tabbox.xml:685:13
set_selectedIndex@chrome://global/content/bindings/tabbox.xml:399:15
set_selectedItem@chrome://global/content/bindings/tabbox.xml:431:34
set_selectedTab@chrome://global/content/bindings/tabbox.xml:110:15
set_selectedTab@chrome://browser/content/tabbrowser.xml:2667:11
_blurTab@chrome://browser/content/tabbrowser.xml:2341:13
removeTab@chrome://browser/content/tabbrowser.xml:2055:13
removeCurrentTab@chrome://browser/content/tabbrowser.xml:2004:13
BrowserCloseTabOrWindow@chrome://browser/content/browser.js:12648:3
oncommand@chrome://browser/content/browser.xul:1:1

[1]    Exit 11                       /opt/firefox-38.0.1/firefox

Comment 4

3 years ago
Are you able able to crash Firefox each time you start it?

If yes, download and install the tool mozregression to find a possible regression range.
See http://mozilla.github.io/mozregression/ for details and FAQ.

If FF36 is OK, just run "mozregression --good-release 36" (no need to bisect, only the changelog is useful)
Flags: needinfo?(ulrich.teichert)
(Reporter)

Comment 5

3 years ago
Hi,

I've downloaded and ran mozregression - I think I found something out which may help reproducing it. I wasn't able to get firefox to crash first (see log below, I needed a retry), because I did not have the stored links available. Seems like my special way after starting firefox:

1. Open a tab
2. click on a link in the bookmarks toolbar

repeat with 4-5 Links like www.dilbert.com, www.garfield.com, www.userfriendly.org, www.gmx.de, www.formular1.com, www.reichelt.de and switch back to a tab during load is related to the crashes.
I always switch the tab-view to blank and add menue bar and bookmark bar.

Log from mozgregreesion:

teres:~> mozregression --good-release 36 
/usr/local/lib/python2.7/dist-packages/requests/packages/urllib3/util/ssl_.py:90: InsecurePlatformWarning: A true SSLContext object is not available. This prevents urllib3 from configuring SSL appropriately and may cause certain SSL connections to fail. For more information, see https://urllib3.readthedocs.org/en/latest/security.html#insecureplatformwarning.
  InsecurePlatformWarning
 0:01.35 LOG: MainThread INFO No 'bad' date specified, using 2015-05-16
 0:01.36 LOG: MainThread INFO Using 'good' date 2014-11-28 for release 36
 0:14.56 LOG: MainThread Bisector INFO Downloading build from: http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2015/02/2015-02-21-03-02-08-mozilla-central/firefox-38.0a1.en-US.linux-i686.tar.bz2
===== Downloaded 100% =====
 1:42.01 LOG: MainThread Test Runner INFO Running nightly for 2015-02-21
 2:52.50 LOG: MainThread Test Runner INFO Launching /tmp/tmpHGgbGP/firefox/firefox
 2:52.53 LOG: MainThread mozversion INFO application_buildid: 20150221030208
 2:52.53 LOG: MainThread mozversion INFO application_changeset: 5de3af90c494
 2:52.54 LOG: MainThread mozversion INFO application_display_name: Nightly
 2:52.54 LOG: MainThread mozversion INFO application_id: {ec8030f7-c20a-464f-9b0e-13a3a9e97384}
 2:52.54 LOG: MainThread mozversion INFO application_name: Firefox
 2:52.54 LOG: MainThread mozversion INFO application_remotingname: firefox
 2:52.54 LOG: MainThread mozversion INFO application_repository: https://hg.mozilla.org/mozilla-central
 2:52.54 LOG: MainThread mozversion INFO application_vendor: Mozilla
 2:52.54 LOG: MainThread mozversion INFO application_version: 38.0a1
 2:52.54 LOG: MainThread mozversion INFO platform_buildid: 20150221030208
 2:52.54 LOG: MainThread mozversion INFO platform_changeset: 5de3af90c494
 2:52.54 LOG: MainThread mozversion INFO platform_repository: https://hg.mozilla.org/mozilla-central
 2:52.54 LOG: MainThread mozversion INFO platform_version: 38.0a1
Was this nightly build good, bad, or broken? (type 'good', 'bad', 'skip', 'retry' or 'exit' and press Enter): retry
 7:35.48 LOG: MainThread Bisector INFO Using local file: /tmp/tmpUvTNGy/2015-02-21--mozilla-central--firefox-38.0a1.en-US.linux-i686.tar.bz2
 7:35.49 LOG: MainThread Test Runner INFO Running nightly for 2015-02-21
 8:36.32 LOG: MainThread Test Runner INFO Launching /tmp/tmpriZMUN/firefox/firefox
 8:36.35 LOG: MainThread mozversion INFO application_buildid: 20150221030208
 8:36.35 LOG: MainThread mozversion INFO application_changeset: 5de3af90c494
 8:36.35 LOG: MainThread mozversion INFO application_display_name: Nightly
 8:36.35 LOG: MainThread mozversion INFO application_id: {ec8030f7-c20a-464f-9b0e-13a3a9e97384}
 8:36.36 LOG: MainThread mozversion INFO application_name: Firefox
 8:36.36 LOG: MainThread mozversion INFO application_remotingname: firefox
 8:36.36 LOG: MainThread mozversion INFO application_repository: https://hg.mozilla.org/mozilla-central
 8:36.36 LOG: MainThread mozversion INFO application_vendor: Mozilla
 8:36.36 LOG: MainThread mozversion INFO application_version: 38.0a1
 8:36.36 LOG: MainThread mozversion INFO platform_buildid: 20150221030208
 8:36.36 LOG: MainThread mozversion INFO platform_changeset: 5de3af90c494
 8:36.36 LOG: MainThread mozversion INFO platform_repository: https://hg.mozilla.org/mozilla-central
 8:36.37 LOG: MainThread mozversion INFO platform_version: 38.0a1
Was this nightly build good, bad, or broken? (type 'good', 'bad', 'skip', 'retry' or 'exit' and press Enter): bad

===================

Here it crashed exactly like before and a crash report was submitted.

===================

16:01.07 LOG: MainThread Bisector INFO Narrowed nightly regression window from [2014-11-28, 2015-05-16] (169 days) to [2014-11-28, 2015-02-21] (85 days) (~6 steps left)
16:01.07 LOG: MainThread Bisector INFO Using local file: /tmp/tmpUvTNGy/2015-01-10--mozilla-central--firefox-37.0a1.en-US.linux-i686.tar.bz2 (downloaded in background)
16:07.78 LOG: MainThread Test Runner INFO Running nightly for 2015-01-10
17:19.20 LOG: MainThread Test Runner INFO Launching /tmp/tmptctyqc/firefox/firefox
17:19.25 LOG: MainThread mozversion INFO application_buildid: 20150110030201
17:19.26 LOG: MainThread mozversion INFO application_changeset: bb8d6034f5f2
17:19.26 LOG: MainThread mozversion INFO application_display_name: Nightly
17:19.26 LOG: MainThread mozversion INFO application_id: {ec8030f7-c20a-464f-9b0e-13a3a9e97384}
17:19.26 LOG: MainThread mozversion INFO application_name: Firefox
17:19.26 LOG: MainThread mozversion INFO application_remotingname: firefox
17:19.26 LOG: MainThread mozversion INFO application_repository: https://hg.mozilla.org/mozilla-central
17:19.26 LOG: MainThread mozversion INFO application_vendor: Mozilla
17:19.26 LOG: MainThread mozversion INFO application_version: 37.0a1
17:19.26 LOG: MainThread mozversion INFO platform_buildid: 20150110030201
17:19.26 LOG: MainThread mozversion INFO platform_changeset: bb8d6034f5f2
17:19.27 LOG: MainThread mozversion INFO platform_repository: https://hg.mozilla.org/mozilla-central
17:19.27 LOG: MainThread mozversion INFO platform_version: 37.0a1
Was this nightly build good, bad, or broken? (type 'good', 'bad', 'skip', 'retry', 'back' or 'exit' and press Enter): bad

======================

This crash looked entirely different from above and the crash reported failed to submit a log. I stopped bisecting here.


Please let me know If I can help you further,
Uli
(Reporter)

Comment 6

3 years ago
Hi,

sorry, forgot to add that there was a segfault in the syslog:

May 16 17:15:03 teres kernel: [ 1920.504934] Web Content[7507]: segfault at 0 ip b3a297a3 sp bf7fe770 error 4 in libxul.so[b3982000+3a1a000]

During the first crash,

CU,
Uli
Flags: needinfo?(ulrich.teichert)

Comment 7

3 years ago
But did you get a pushlog?
(Like http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=dac5700acf8b&tochange=cb573b9307e5 )

Just run the tool, each time a build is downloaded and launched, make the test and enter if it's bad or good (no need of the crash data), you should obtain a range with last good build and the 1st bad build.
(Reporter)

Comment 8

2 years ago
Hi,

yes:

https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=8850aa0f5332&tochange=67872ce17918

HTH,
Uli

Updated

2 years ago
Severity: normal → critical
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: crash, regression
Version: 38 Branch → 37 Branch

Updated

2 years ago
Component: Untriaged → Tabbed Browser

Comment 9

2 years ago
Hello,

I confirm that I have the same problem as Ulrich, i.e. all Firefox builds
*after* 36.0.4 crash nearly randomly (2-3 times a day) with no apparent
pattern, except that I have more than one window open, and the Firefox reporter
is unable to report the error.  The crashes only happen on my Linux 32-bit system
(Fedora 14 kernel 2.6.35.14-106.fc14.i686.PAE) while another system running
Fedora 15 x86_64 has no problem at all.  The only thing that I found is (again
like Ulrich), there is a segfault in syslog:
Jun  1 11:01:03 albeniz kernel: [ 5891.150146] Chrome_ChildThr[16533]: segfault at 0 ip 00735baf sp b5df3a80 error 6 in libmozalloc.so[734000+4000]

Hope somebody can understand the cause of the problem ...

Comment 10

2 years ago
Hi again,

I collected the logs of all crashes since a few days and it seems to always be the same
problem ...

Jun  1 13:07:36 albeniz kernel: [13481.450983] Chrome_ChildThr[488]: segfault at 0 ip 00211baf sp b5cf3a80 error 6 in libmozalloc.so[210000+4000]
Apr 28 17:57:12 albeniz kernel: [30257.604179] Chrome_ChildThr[4286]: segfault at 0 ip 008b9baf sp b5cb3a80 error 6 in libmozalloc.so[8b8000+4000]
Apr 29 14:16:37 albeniz kernel: [17289.029427] Chrome_ChildThr[8903]: segfault at 0 ip 00464baf sp b5bb3a80 error 6 in libmozalloc.so[463000+4000]
Apr 29 14:29:39 albeniz kernel: [18071.522920] Chrome_ChildThr[15429]: segfault at 0 ip 001d4baf sp b5cb3a80 error 6 in libmozalloc.so[1d3000+4000]
Apr 29 15:27:19 albeniz kernel: [21529.120511] Chrome_ChildThr[21864]: segfault at 0 ip 0035abaf sp b5db3a80 error 6 in libmozalloc.so[359000+4000]
May 12 09:47:01 albeniz kernel: [ 1403.305683] Chrome_ChildThr[6091]: segfault at 0 ip 00aedbaf sp b5cb3a80 error 6 in libmozalloc.so[aec000+4000]
May 12 12:50:15 albeniz kernel: [12391.818210] Chrome_ChildThr[10644]: segfault at 0 ip 0013bbaf sp b5bb3a80 error 6 in libmozalloc.so[13a000+4000]
May 13 12:53:38 albeniz kernel: [11690.739718] Chrome_ChildThr[1614]: segfault at 0 ip 00bf4baf sp b5ef3a80 error 6 in libmozalloc.so[bf3000+4000]
May 20 12:35:07 albeniz kernel: [10093.264446] Chrome_ChildThr[32409]: segfault at 0 ip 00531baf sp b5ef3a80 error 6 in libmozalloc.so[530000+4000]
May 20 14:59:50 albeniz kernel: [18772.955196] Chrome_ChildThr[22842]: segfault at 0 ip 006afbaf sp b5ef3a80 error 6 in libmozalloc.so[6ae000+4000]
May 24 22:26:07 albeniz kernel: [ 2668.862104] Chrome_ChildThr[5809]: segfault at 0 ip 00a09baf sp b5ef3a80 error 6 in libmozalloc.so[a08000+4000]
May 24 22:36:39 albeniz kernel: [ 3300.071788] Chrome_ChildThr[9981]: segfault at 0 ip 00473baf sp b5df3a80 error 6 in libmozalloc.so[472000+4000]
May 26 12:13:37 albeniz kernel: [11261.063459] Chrome_ChildThr[29947]: segfault at 0 ip 00e2bbaf sp b5df3a80 error 6 in libmozalloc.so[e2a000+4000]
May 26 12:14:28 albeniz kernel: [11311.840621] Chrome_ChildThr[30653]: segfault at 0 ip 00f5abaf sp b5cf3a80 error 6 in libmozalloc.so[f59000+4000]
May 26 14:03:20 albeniz kernel: [17840.627106] Chrome_ChildThr[18598]: segfault at 0 ip 00dd7baf sp b5df3a80 error 6 in libmozalloc.so[dd6000+4000]
May 26 14:03:48 albeniz kernel: [17868.463371] Chrome_ChildThr[19402]: segfault at 0 ip 0027bbaf sp b5ef3a80 error 6 in libmozalloc.so[27a000+4000]
May 28 14:48:01 albeniz kernel: [20381.452316] Chrome_ChildThr[17323]: segfault at 0 ip 001fdbaf sp b5df3a80 error 6 in libmozalloc.so[1fc000+4000]
May 30 11:26:57 albeniz kernel: [ 5840.872233] Chrome_ChildThr[16242]: segfault at 0 ip 0081dbaf sp b5ef3a80 error 6 in libmozalloc.so[81c000+4000]
May 30 11:29:22 albeniz kernel: [ 5985.202908] Chrome_ChildThr[16604]: segfault at 0 ip 00458baf sp b5ef3a80 error 6 in libmozalloc.so[457000+4000]
Jun  1 11:01:03 albeniz kernel: [ 5891.150146] Chrome_ChildThr[16533]: segfault at 0 ip 00735baf sp b5df3a80 error 6 in libmozalloc.so[734000+4000]

Comment 11

2 years ago
Hello,

just 2 additional comments:
1) Firefox 39.0 still crashes in the same way (on a 32-bit system)
2) Opening www.skype.com causes the crash immediately whatever the other open tab

This is really annoying and I am beginning to think of dropping Firefox after many years,
but I cannot continue to use Firefox 36 which is really getting too old.

If I can help, tell me, but I am not a developer, so I don't think I can do a lot

Comment 12

2 years ago
Alain, coud you confirm the regression range found by Ulrich in comment #8?
You don't need to download mozregression, but just run the 2 builds (last good and first bad) near the end of December 2014:
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2014/12/
(select the folder mozilla-central, and I guess the range is between 12/29 and 12/30)
Flags: needinfo?(anz)

Comment 13

2 years ago
I'm sorry to say that I cannot confirm the regression range of Ulrich.
I tried installing and running the files firefox-37.0a1.en-US.linux-i686.tar.bz2
(that is, firefox-37 rather than firefox-38 as Ulrich did)
that I found in the directories <date>-mozilla-central/ and none crashed, even
the latest one that I found in 2015-01-12-03-02-01-mozilla-central/
(while the released firefox-37.0 that is still installed on my machine crashes
immediately if opening www.skype.com).
As I didn't know where or what to look for to continue, I stopped there.

Comment 14

2 years ago
Tanks for the feedback. The next step is to use Mozregression to find a regression range on your side.

Comment 15

2 years ago
Hello,

I am happy to say that it seems that, at least for me, this bug/problem disappeared with Firefox 40.0.3
that fixed bug 1145230 https://bugzilla.mozilla.org/show_bug.cgi?id=1145230 that also appeared with
Firefox 37.
So the problem probably was not related to 32 vs 64 bits, but to the use of an old Fedora 14 with old
gstreamer and libc.
Still, it's very nice that it now seems to be fixed.
Thanks !
Flags: needinfo?(anz)

Comment 16

2 years ago
Ulrich, does it still crash for you with 40.0.3?
Flags: needinfo?(ulrich.teichert)
(Reporter)

Comment 17

2 years ago
Hi Loic,

I've tried 40.0.3 last weekend, but was running out of time testing it. I'll continue testing as soon as possible and will update the bug afterwards,

regards,
Uli
(Reporter)

Comment 18

2 years ago
Hi,

eventually, I had the time to retest this fully: I can confirm that this does not happen with 40.0.3 *and* 39.0.3.

Thanks for fixing this,
CU,
Uli
(Reporter)

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
(Reporter)

Updated

2 years ago
Flags: needinfo?(ulrich.teichert)
You need to log in before you can comment on or make changes to this bug.