Mozilla 0.9.7 hangs on 'mozilla not default browser' dialog

VERIFIED WORKSFORME

Status

SeaMonkey
UI Design
--
critical
VERIFIED WORKSFORME
16 years ago
13 years ago

People

(Reporter: David K, Assigned: Bill Law)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Mozilla 0.9.7 (2001122106) hangs on startup.  Specifically, when I get to the
'Mozilla is not the default browser.  Do you want to set it as the
default browser?  Yes | No | Cancel'
If I click yes, mozilla hangs and I have to CTRL-ALT-DELETE-End Task
to get rid of it
If I click no, mozilla starts normally.

What I did to install:
1.  I uninstalled my old mozilla then deleted the mozilla.org directory
2.  I installed mozilla-win32-0.9.7-installer.exe, choosing NOT to use
the quick loader
3.  As described above, the default browser dialog crashes mozilla

The install is fresh because the previous version was deleted.  My
profile was created a few months ago by an earlier release of mozilla.
There are no other plugins installed.
(Reporter)

Updated

16 years ago
OS: Windows 2000 → Windows XP
(Reporter)

Comment 1

16 years ago
I've tried this with a fresh user profile and it still hangs the same way.

Comment 2

16 years ago
->XPApps
Assignee: asa → pchen
Component: Browser-General → XP Apps
QA Contact: doronr → sairuh
bill?
Assignee: pchen → law
Is this still a problem with 0.9.8 or later ?
(Reporter)

Comment 5

16 years ago
Yes, it still hangs.  I did a directory-delete fresh install for 0.9.8.
After choosing yes at the 'make default browser' dialog it attempts to
load the default web page and fails.
As soon as I click anywhere in the browser window it's status changes
to [Application Not Responding] and I have to Ctrl-Alt-Delete to get
rid of it.
Can you try a new profile with "mozilla -profilemanager" ?
Do you run Mozilla as root ?

(Reporter)

Comment 7

16 years ago
I tried 'mozilla -profilemanager' and did it with a new profile.
This time when I went 'Tasks > Navigator' from the mail program
the mail program hung before the browser window even appeared.

On windows XP I don't know how to tell if I'm logged on as root
or not.  I don't think so though.
root= Administrator rights

(use Start/run/lusrmgr.msc , select User,double click on your user name and look
if you are in the group 2administrator")
(Reporter)

Comment 9

16 years ago
Yes, I am part of the administrator group
Do you run any background applications ?
(Virus scanner ...)

That's the last thing that i know... :-(
(Reporter)

Comment 11

16 years ago
I turned off all my taskbar apps and closed all other applications.
It's still happening :(

Comment 12

16 years ago
I just successfully made Mozilla my default browser with no problems at all.
Marking WFM. Reporter, if you can get this to reoccur with recent builds on a
test profile, feel free to reopen. Marking WFM.

Win XP Pro Gold,
2002033009
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Comment 13

16 years ago
*** Bug 129278 has been marked as a duplicate of this bug. ***

Comment 14

16 years ago
*** Bug 151868 has been marked as a duplicate of this bug. ***
mass-verifying WorksForMe bugs.

reopen only if this bug is still a problem with a *recent trunk build*.

mail search string for bugspam: AchilleaMillefolium
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.