Add-ons Manager shows incorrect add-on version (global extension update not detected)

UNCONFIRMED
Unassigned

Status

()

Toolkit
Add-ons Manager
UNCONFIRMED
3 years ago
2 years ago

People

(Reporter: FredMcD, Unassigned)

Tracking

38 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(4 attachments)

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:38.0) Gecko/20100101 Firefox/38.0
Build ID: 20150513174244

Steps to reproduce:

I sent this message to the Free Downloads Manager Support;

Mozilla Firefox thinks that I have FDM v1.7.3  Today, I downloaded
v3.9.5, but Firefox still shows 1.7.3  and not compatible.



Actual results:

Firefox is not showing the correct version for this program. And it is now disabled.
(Reporter)

Comment 1

3 years ago
Forgot to add, I had deleted pluginreg.dat  The problem remains.
(Reporter)

Comment 2

3 years ago
Created attachment 8606581 [details]
Capture1.JPG;
(Reporter)

Comment 3

3 years ago
Created attachment 8606582 [details]
Capture2.JPG

Comment 4

3 years ago
Free Download Manager 3.9.5 build 1542 comes bundled with Free Download Manager plugin 1.7.3.1, which is an extension. I see it as compatible and enabled. Update your version of Free Download Manager, then restart Firefox.

(In reply to FredMcD from comment #1)
> Forgot to add, I had deleted pluginreg.dat  The problem remains.

That only affects plug-ins (things like Flash Player). To accomplish what you want for extensions, see the following support article. Though there's no point in doing so, unless you're still stuck with version 1.7.3 after updating.
https://support.mozilla.org/en-US/kb/unable-install-add-ons-extensions-or-themes#w_corrupt-extension-files
Component: Untriaged → Extension Compatibility
Flags: needinfo?(FredMcD)
Summary: Firefox Add-ons Manager shows incorrect add-on version → Free Download Manager plugin 1.7.3 is incompatible with Firefox 38.0.1
(Reporter)

Comment 5

3 years ago
Thank you Gingerbread Man for replying. I checked the article. It said;

4 Delete the following files:

    extensions.sqlite
    extensions.sqlite-journal (if found)
    extensions.ini
    extensions.json 

What I found was I only had the INI and JSON files. But I also had another file: EXTENSIONS.LOG
I looked in the file, and found the same message being repeated over and over starting 2015-05-02.
The line reads; 2015-05-15 22:39:36 ERROR [fireie]: updateInterface() failed: TypeError: tab is undefined at resource://fireie/AppIntegration.jsm:617
----------------------
After deleting all the Extensions.* files, I started Firefox. The INI and JSON were restored. But no
SQLITE file. It now shows Free Download Manager plugin v1.7.3.1 and it is now compatible.

Can not having the SQLITE file be a problem?
Flags: needinfo?(FredMcD)

Comment 6

3 years ago
(In reply to Gingerbread Man from comment #4)
> Update your version of Free Download Manager, then restart Firefox.

You were already using the latest version. Looks like you hit some variation of bug 567080.

(In reply to FredMcD from comment #5)
> After deleting all the Extensions.* files, I started Firefox. The INI and
> JSON were restored. But no SQLITE file. It now shows Free Download Manager
> plugin v1.7.3.1 and it is now compatible.
> 
> Can not having the SQLITE file be a problem?

No, that's normal. Some of the files listed in the support article are no longer in use in the current version of Firefox.
Component: Extension Compatibility → Add-ons Manager
Product: Firefox → Toolkit
Summary: Free Download Manager plugin 1.7.3 is incompatible with Firefox 38.0.1 → Add-ons Manager shows incorrect add-on version (global extension update not detected)
(Reporter)

Comment 7

3 years ago
Other than not having a SQLITE file, it looks the same. Is there some kind of problem with the Add-ons Manager as to updates? Should the user delete these and other Firefox file? Like once a month?
I am using https://addons.mozilla.org/en-US/firefox/addon/places-maintenance/
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME

Comment 8

3 years ago
(In reply to FredMcD from comment #7)
> Is there some kind of problem with the Add-ons Manager as to updates?

That's what bug reports are supposed to determine. Even though you worked around the issue, I figured you'd leave this open so a developer can have a look at it. Like I said, it looks to me like the global extension was updated and Firefox failed to notice. This is a similar situation to bug 567080, where the user modified the extension manually (in both cases, the extension wasn't updated via the Add-ons Manager).

> Should the user delete these and other Firefox file? Like once a month?

I certainly hope not. Firefox is supposed to work without having to ever manually delete files, especially not on a regular basis.

> I am using https://addons.mozilla.org/en-US/firefox/addon/places-maintenance/

That affects places.sqlite, the database that stores history and bookmarks. It doesn't affect the add-ons database.
(Reporter)

Comment 9

3 years ago
So, how to set this bug so the developers take a good look at the issue?
(Reporter)

Updated

3 years ago
Severity: normal → major

Comment 10

3 years ago
(In reply to FredMcD from comment #9)
> So, how to set this bug so the developers take a good look at the issue?

Leave it open.

Please don't inappropriately set the Importance field (Priority + Severity).
https://bugzilla.mozilla.org/page.cgi?id=fields.html#bug_severity
Severity: major → normal
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
See Also: → bug 567080

Updated

2 years ago
Duplicate of this bug: 1167583

Comment 12

2 years ago
> Bug 567080, comment 6

In that case, the extension files were edited manually. What about global extensions, when the files are updated by an external application? Is this a case worth handling differently?
Flags: needinfo?(dtownsend)
As in bug 1167583 it is possible that updating Free Download Manager isn't changing the file modification times of the add-on's files. This would mean Firefox isn't rescanning the install.rdf. Can either of you test that?
Flags: needinfo?(dtownsend)
(Reporter)

Comment 14

2 years ago
I can try, but you have to tell me what to do,
Flags: needinfo?(dtownsend)
You'll need to install the old FDM and start Firefox. Grab a copy of the pref extensions.xpiState from about:config. Then exit and from a command prompt go to the extension's directory and run "dir /s" and copy the output.

Then install the new FDM, start Firefox and verify that it hasn't updated the add-on version. Get the pref extensions.xpiState again and do the "dir /s" from the command prompt again. Copy all that into this bug report, probably best as a text attachment.
Flags: needinfo?(dtownsend)

Comment 16

2 years ago
Created attachment 8609721 [details]
Output for comment 15.txt
Can you also zip up the contents of C:\Program Files\Free Download Manager\Firefox\extension at that last point and attach here?
Flags: needinfo?(gingerbread_man)

Comment 18

2 years ago
Created attachment 8609876 [details]
Archive for comment 17.zip
Flags: needinfo?(gingerbread_man)
You need to log in before you can comment on or make changes to this bug.