Add-ons can't use sdk/tabs - "modelFor is not defined" error on Firefox for Android

RESOLVED DUPLICATE of bug 1163816

Status

()

Core
General
--
major
RESOLVED DUPLICATE of bug 1163816
3 years ago
6 months ago

People

(Reporter: Alexander, Unassigned)

Tracking

40 Branch
ARM
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
My add-on tries this:

var tabs = require("sdk/tabs");

Console shows this:

[JavaScript Error: "ReferenceError: modelFor is not defined"]
Message: ReferenceError: modelFor is not defined
Stack:
@resource://gre/modules/commonjs/sdk/tabs/tab-fennec.js:13:154

Both 40 and 41 branches has the same issue. 38 and 39 work fine. What is "modelFor" there for?

Updated

3 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1163816
Moving from Core::Untriaged to Core::General https://bugzilla.mozilla.org/show_bug.cgi?id=1407598
Component: Untriaged → General
You need to log in before you can comment on or make changes to this bug.