Support new "Middle Click" event from Kensington mice on MacOS

RESOLVED DUPLICATE of bug 106692

Status

()

Core
Event Handling
--
minor
RESOLVED DUPLICATE of bug 106692
16 years ago
15 years ago

People

(Reporter: Andrew Thompson, Assigned: Steve Dagley)

Tracking

Trunk
mozilla1.0
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Kensington's new Mac OS X drivers (just released, version 1.1) have an explicit
middle click button action, rather than emulating it by using a combination of a
button and a key (eg, shift).

I set my mouse up to use this event, but Mozilla ignores it altogether. We
should  probably try to arrange to treat it like cmd-click, or simply pass it
through as "Button 2" as I assume most of the XP code will understand that.

(by "button 2" I mean, if one has a 3 button mouse and is right handed, the left
button is button 1, the rightmost button is button 3 and the one in the middle
is button 2 - ie, X11 style...)

Pink - do you know how this will work, or maybe you could drop a note to your
contact at Kensington asking for info?
dagley was talking to me about this over the holidays
Assignee: joki → sdagley
(Assignee)

Comment 2

16 years ago
Actually it's a Carbon mouse event, or it had better be if they want us to 
support it.  Look in the CarbonEvent docs for kEventMouseButtonTertiary.
(Assignee)

Comment 3

16 years ago
Setting TFV and dependency
Depends on: 106692
Target Milestone: --- → mozilla0.9.9
(Assignee)

Comment 4

16 years ago
-> mozilla1.0
Target Milestone: mozilla0.9.9 → mozilla1.0

Comment 5

16 years ago

*** This bug has been marked as a duplicate of 106692 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Updated

16 years ago
QA Contact: madhur → rakeshmishra

Updated

15 years ago
QA Contact: rakeshmishra → trix
You need to log in before you can comment on or make changes to this bug.