Closed Bug 1165795 Opened 5 years ago Closed 4 years ago

[FFOS7715 v2.1] [dolphin] Firefox OS 2.1s version's Homescreen can not change to landscape mode.

Categories

(Firefox OS Graveyard :: Gaia::Homescreen, defect, major)

ARM
Gonk (Firefox OS)
defect
Not set
major

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: lin.hui, Unassigned)

References

Details

Firefox OS 2.1s version's Homescreen can not change to landscape mode.

Homescreen is always displays in vertical mode, at some cases may cause some performance issue.

First one: 
Playing video at landscape mode, click home-button to back to homescreen, the time consume about 2 seconds.

The second:
Playing video at landscape mode, click home-button to back to homescreen, then click video icon open the video again, the video's control-bar displayed in the middle of the screen firstly then recover at bottom.

If homescreen app can change to landscape mode, this two issues have gone, but when homescreen change to landscape mode, the app icons displays not suit the screen.

So I need help, whether we should do some change about the homescreen in landscape mode.
Hi Vance :

Like the description says, please help to find a partner to investigate this issue.

Thank you.
Flags: needinfo?(vchen)
Hi Vance:

Please help to find a partner to investigate this issue, or give a further explanation.

Really thanks.
First of all, since from 2.1 we change the homescreen to vertical style, it is correct behavior that homescreen won't change to landscape display even if you rotate the screen. 

Hi Chens, from the reproduced video[1], you can see that indeed when we launch the video app from the home screen, the video app will first display in portrait mode then switch to landscape more. Is there anything we can do to remove this necessary transition?

Thanks

[1] https://www.youtube.com/watch?v=Nd13vbvPtWM&feature=youtu.be
Flags: needinfo?(vchen) → needinfo?(chens)
There's a technical limitation for now that B2G has only one orientation lock across the system. That means all the apps must be rendered in the same orientation at the same time.

During the transition animation of launching app, there should be two apps displayed on the screen simultaneously. If these two apps require different orientation (say, homescreen in portrait but video app in landscape), we can only deal this situation with either rotating the homescreen to landscape mode (with broken layout) prior to starting launching video app or rotating the video app until homescreen is fully disappeared. The latter is our current behavior and is also the reason why we're encountering this issue. Bug 1043102 is the bug trying to resolve this limitation but can't help for v2.1 for sure.

I would suggest to consult UX to see whether we can workaround it by showing something like screenshot or blank screen during the transition if we do need to fix it. Though I'm afraid it may cause regressions.
clearing ni and thanks Luke for the explanation.
Flags: needinfo?(chens)
Mass update: Resolve wontfix all issues with legacy homescreens.

As of 2.6 we have a new homescreen and having these issues open is confusing. All issues will block bug 1231115 so we can use that to re-visit any of these if needed.
Blocks: 1231115
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.