[RTL][Contacts]The name and address are truncated at wrong side at select Gmail contacts view.

VERIFIED FIXED in 2.2 S13 (29may)

Status

defect
P2
normal
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: lulu.tian, Assigned: arcturus)

Tracking

unspecified
2.2 S13 (29may)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [2.2-nexus-5-l])

Attachments

(3 attachments)

(Reporter)

Description

4 years ago
[1.Description]:
[RTL][Flame v2.2&v3.0][Nexus 5 2.2&3.0][Contacts]The long LTR name and long LTR address are truncated at left side of text at select Gmail contacts view.
See attachment:Import contacts from Gmail.png

[2.Testing Steps]: 
Prerequisite: Have a contacts with long LTR name and long LTR address in Gmail account.
1. Set system language as Arabic.
2. Launch Contacts.
3. Tap Settings -> Import Contacts.
4. Tap Gmail and login a gmail account.
5. Observe the select contacts view.

[3.Expected Result]: 
5. The name and address should be truncated at right side of LTR text.

[4.Actual Result]: 
5. The contacts with long LTR name and long LTR address are truncated at left side.

[5.Reproduction build]: 
Device: Flame 2.2 (affected)
Build ID               20150517002501
Gaia Revision          b388a235e89dab76c24323767cd87ebd7c4c8b17
Gaia Date              2015-05-15 16:08:41
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/54ae7c7182bc
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150517.041427
Firmware Date          Sun May 17 04:14:38 EDT 2015
Bootloader             L1TC000118D0

Device: Flame 3.0 (affected)
Build ID               20150517010201
Gaia Revision          4c0f36e9dfe017bf2a698d416a57c8156b43383d
Gaia Date              2015-05-15 22:18:51
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/2f6ea66057fe
Gecko Version          41.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150517.044012
Firmware Date          Sun May 17 04:40:23 EDT 2015
Bootloader             L1TC000118D0

Device: Nexus 5 2.2 (affected)
Build ID               20150517002501
Gaia Revision          b388a235e89dab76c24323767cd87ebd7c4c8b17
Gaia Date              2015-05-15 16:08:41
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/54ae7c7182bc
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150517.041034
Firmware Date          Sun May 17 04:10:50 EDT 2015
Bootloader             HHZ12f

Device: Nexus 5 3.0 (affected)
Build ID               20150517010201
Gaia Revision          4c0f36e9dfe017bf2a698d416a57c8156b43383d
Gaia Date              2015-05-15 22:18:51
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/2f6ea66057fe
Gecko Version          41.0a1
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150517.043539
Firmware Date          Sun May 17 04:35:55 EDT 2015
Bootloader             HHZ12f

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
(Reporter)

Updated

4 years ago
QA Whiteboard: [rtl-impact]
Duplicate of this bug: 1126883
With the confusion about the place of ellipsis in LTR words in RTL UIs (see bug 1126587), bug 1126883 has not fixed the email addresses in the import lists. Delphine, from an l10n POV, would you block 2.2 on it?
Flags: needinfo?(lebedel.delphine)
Duplicate of this bug: 1165826
Duplicate of this bug: 1165828
Hi Johan - this can in fact lead to some confusion. However the length of both the name and email here seem kind of an edge case to me (ie. you would probably still be able to guess from what you see)
I'm torn for this one - so given the above, I would like general triage decision.
blocking-b2g: --- → 2.2?
Flags: needinfo?(lebedel.delphine)
Priority: -- → P2
Comms triage: This is breaking the first time experience for RTL-readers.
blocking-b2g: 2.2? → 2.2+
Hi Wesley,
Can you help to find someone who can help fixing this issue?
Thanks!
Flags: needinfo?(whuang)
reminder: FxOS 2.2 code complete = 6/8.
Flags: needinfo?(whuang) → needinfo?(francisco)
Flags: needinfo?(francisco)
Attachment #8611265 - Flags: review?(ferjmoreno)

Updated

4 years ago
Assignee: nobody → francisco
Attachment #8611265 - Flags: review?(ferjmoreno) → review+
Landed:

https://github.com/mozilla-b2g/gaia/commit/ff9786035c6a5cfe8c4ce9fb8526379b9d588335
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Comment on attachment 8611265 [details] [review]
[gaia] arcturus:bug-1165824 > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
RTL regression
[User impact] if declined:
Bad user experience
[Testing completed]:
Tested on master
[Risk to taking this patch] (and alternatives if risky):
Very low
[String changes made]:
None
Attachment #8611265 - Flags: approval-gaia-v2.2?

Updated

4 years ago
Attachment #8611265 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
(Reporter)

Comment 13

4 years ago
This issue has been verified as pass on latest build of Flame 2.2/3.0 and Nexus5 2.2/3.0 by STRs in comment 0.
Result: The name and address are truncated at right side of LTR text.
See attachment:verify_gmail_pass.png
Rate:0/5

Device: Flame 2.2 (pass)
Build ID               20150531162502
Gaia Revision          b4582cc394e0919623263997c0cdb0b4751a1403
Gaia Date              2015-05-31 11:06:34
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/78d8b0a4303d
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150531.195816
Firmware Date          Sun May 31 19:58:28 EDT 2015
Bootloader             L1TC000118D0

Device: Flame 3.0 (pass)
Build ID               20150531160203
Gaia Revision          e6dc0f4c583407a4a52a66ce7cb11f058302a762
Gaia Date              2015-05-29 17:20:26
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/f8d21278244b
Gecko Version          41.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150531.192324
Firmware Date          Sun May 31 19:23:35 EDT 2015
Bootloader             L1TC000118D0

Device: Nexus 5 2.2 (pass)
Build ID               20150531002502
Gaia Revision          0a46394dbee0ed2eb71a136cee38ddd8549dd597
Gaia Date              2015-05-30 14:50:16
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/ed2f6aeb1d81
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150531.043812
Firmware Date          Sun May 31 04:38:27 EDT 2015
Bootloader             HHZ12f

Device: Nexus 5 3.0 (pass)
Build ID               20150531160203
Gaia Revision          e6dc0f4c583407a4a52a66ce7cb11f058302a762
Gaia Date              2015-05-29 17:20:26
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/f8d21278244b
Gecko Version          41.0a1
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150531.192050
Firmware Date          Sun May 31 19:21:07 EDT 2015
Bootloader             HHZ12f
(Reporter)

Updated

4 years ago
Status: RESOLVED → VERIFIED
QA Whiteboard: [rtl-impact] → [rtl-impact][MGSEI-Triage+]
You need to log in before you can comment on or make changes to this bug.