[bluetooth2] Fix build break resulting from Bug 1164292

RESOLVED FIXED in Firefox 41

Status

RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: jocelyn, Assigned: jocelyn)

Tracking

unspecified
2.2 S13 (29may)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(firefox41 fixed)

Details

(Whiteboard: [webbt-api])

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

3 years ago
Bug 1164292 revise the function signature of nsIPrincipal::GetOrigin.
We need to revise our function call at https://dxr.mozilla.org/mozilla-central/source/dom/bluetooth/bluetooth2/BluetoothAdapter.cpp#986 to fix the build break.
(Assignee)

Comment 1

3 years ago
Created attachment 8606934 [details] [diff] [review]
Bug 1165835: Fix bluetooth2 build break resulting from Bug 1164292.

Hi Ben,

Please help to review my patch.

Thanks,
Jocelyn
Attachment #8606934 - Flags: review?(btian)

Comment 2

3 years ago
Comment on attachment 8606934 [details] [diff] [review]
Bug 1165835: Fix bluetooth2 build break resulting from Bug 1164292.

Review of attachment 8606934 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM.
Attachment #8606934 - Flags: review?(btian) → review+
(Assignee)

Comment 3

3 years ago
Created attachment 8606946 [details] [diff] [review]
Bug 1165835: Fix bluetooth2 build break resulting from Bug 1164292. r=btian

Thanks, Ben.
Attachment #8606934 - Attachment is obsolete: true
(Assignee)

Comment 4

3 years ago
* no try server result since bluetooth2 won't be built.
Keywords: checkin-needed
(Assignee)

Updated

3 years ago
Duplicate of this bug: 1165872
https://hg.mozilla.org/mozilla-central/rev/e115d9fb3e04
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-firefox41: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → 2.2 S13 (29may)
You need to log in before you can comment on or make changes to this bug.