Closed Bug 1165859 Opened 8 years ago Closed 8 years ago

Capturing profile crashed [@libc.so!ifree] because of SIGSEGV

Categories

(Core :: Gecko Profiler, defect, P1)

ARM
Gonk (Firefox OS)
defect

Tracking

()

RESOLVED DUPLICATE of bug 1167230
Tracking Status
firefox41 --- affected

People

(Reporter: ting, Assigned: wcosta)

References

Details

Crash Data

Attachments

(1 file)

Attached file dump.txt
STR:
  1. Profile with command |$ ./profile.sh start -p b2g; sleep 5; ./profile.sh capture|
  2. The device is reset when capture, and python throws exception of "Unterminated string starting at:..."

Versions:
  gecko: https://hg.mozilla.org/mozilla-central/rev/35918b0441b4
  gaia: 7ec3f02dbcacc3468a10938f7cd87eb3184939bb
Crash Signature: [@libc.so!ifree]
Summary: Running profiler crashed at libc.so!ifree because of SIGSEGV → Capturing profile crashed [@libc.so!ifree] because of SIGSEGV
It feels like a recent change in gecko tree is causing this bug. I am bisecting to find the guilty commit.
This is caused by Bug 1154115, more precisely commit https://hg.mozilla.org/mozilla-central/rev/ea1f7a05bd32.

shu which is the original author of this patch seems to be in PTO. I am going to make further investigation later.
Assignee: nobody → wcosta
Status: NEW → ASSIGNED
Priority: -- → P1
Blocks: 1154115
Flags: qe-verify+
Possible dup of bug 1167230. wcosta, could you try out the patch in there?
Flags: needinfo?(wcosta)
The crash is over, but b2g profile still doesn't work due to the json file format change. I am going to close this bug as duplicate and file a follow up bug to update b2g profile to the new file format.
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Flags: needinfo?(wcosta)
Resolution: --- → DUPLICATE
See Also: → 1168784
You need to log in before you can comment on or make changes to this bug.