Name of download file is not picked-up right

CLOSED WORKSFORME

Status

--
major
CLOSED WORKSFORME
17 years ago
14 years ago

People

(Reporter: svdmade, Assigned: bugzilla)

Tracking

Trunk
mozilla1.2alpha
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
When downloading files via the mail reader the file name used to save the file
is not correct. The full url is used to save the file instead of the file name
itself. The bug first appeared after moz 0.9.6. example
url is http://1.2.3.4/test/test.avi file name should be test.avi but appears as
http:__1.2.3.4_test_test.avi
front end.
Assignee: mscott → sspitzer
Status: UNCONFIRMED → NEW
Component: Mail Back End → Mail Window Front End
Ever confirmed: true

Comment 2

17 years ago
reassigning to ducarroz.
Assignee: sspitzer → ducarroz
Target Milestone: --- → mozilla1.2
(Reporter)

Comment 3

17 years ago
Using these steps causes the bug to popup

1 Open an email with links in it
2 Use the rightclick menu to select save as
3 The file name will now contain all of the url instead of only the file name

Working is the folowing

1 Open an email with links in it
2 Click the link directly this will ask if the file needs to be saved or opend.
3 Select save 
4 The file name will now show up correctly and save correctly

I hope this makes the bug hunt easier.
(Assignee)

Comment 4

17 years ago
I am not able to reproduce this problem using Mozilla RC1. When doing a RMB on a
link inside a message and choose "Save Link Target as...", a save file dialog
appears with the correct file name.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 5

17 years ago
Using branch builds 20020522 on winxp, mac and linux this worksforme too.
Reporter, right mouse clicking on a link within a message does not give you a
Save As...menu item.  It gives you a "Save Link Target As"... which works
correctly now.  If you still see the problem and if your scenario is not about
selecting a link in the message body, please update your steps and reopen. 
Verified.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 6

17 years ago
Looks as this bug has been squashed
Status: VERIFIED → CLOSED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.