If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

403 Forbidden on svn.mozilla.org for my LDAP account

RESOLVED FIXED

Status

mozilla.org
Repository Account Requests
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: Liu Xing, Assigned: marcia)

Tracking

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:38.0) Gecko/20100101 Firefox/38.0
Build ID: 20150513174244

Steps to reproduce:

I want to commit new .lang files into https://svn.mozilla.org/projects/mozilla.com/trunk/locales/zh-CN/firefox/channel.lang. But I receive this error:

meteor@meteormatt:~/workspace/mozilla.com/locales/zh-CN/firefox$ svn commit -m "add </a> after 给我们提供反馈" --username liuxingmatt@gmail.com --password ***
svn: E175013: Commit failed (details follow):
svn: E175013: POST of '/!svn/me': 403 Forbidden (https://svn.mozilla.org)

Updated

2 years ago
Assignee: server-ops → nobody
Component: Account Requests → MOC: Service Requests
QA Contact: moconnor → lypulong
Have you committed anything there before (has this worked previously) or are you requesting new access?
(Reporter)

Comment 2

2 years ago
(In reply to Peter Radcliffe [:pir] from comment #1)
> Have you committed anything there before (has this worked previously) or are
> you requesting new access?

I already have account see bug 1081485
But it is the first time to use this account on SVN.
If it is new access you'll need people who already have access to vouch for you, this is not the right place to ask in that case.
Assignee: nobody → mozillamarcia.knous
Component: MOC: Service Requests → Repository Account Requests
Product: Infrastructure & Operations → mozilla.org
QA Contact: lypulong
(Reporter)

Comment 4

2 years ago
(In reply to Peter Radcliffe [:pir] from comment #3)
> If it is new access you'll need people who already have access to vouch for
> you, this is not the right place to ask in that case.

You mean I need to ask Josh Matthews [:jdm] bug 1081485?
(Reporter)

Updated

2 years ago
Group: mozilla-employee-confidential
You need to have one or two people (I'm not clear on the requirements from that side) who have access to the section you want access to to vouch for you.

Since I'm a sysadmin, not a developer, I don't know who those people are hence moving this bug into the repository account requests section where it should be.
(Assignee)

Comment 6

2 years ago
To me it looks as if this is a dupe of the original request (Bug 1081485) and he just isn't able to access that repo on mozilla.com/trunk. Perhaps we need to check what bits he was given?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Ok, I wasn't clear it was the same access.

I've made a change to the SVN authz file which may fix this, give it 30 mins to push out to the servers.
Liu Xing does that solve your problem?
Flags: needinfo?(liuxingmatt)
(Reporter)

Comment 9

2 years ago
(In reply to Peter Radcliffe [:pir] from comment #8)
> Liu Xing does that solve your problem?

I will try it tomorrow when I go to the office.
(Reporter)

Comment 10

2 years ago
meteor@meteormatt:~/workspace/mozilla.com/locales/zh-CN/firefox$ svn commit -m "add </a> after 给我们提供反馈" --username liuxingmatt@gmail.com --password 860506@matt00000 

-----------------------------------------------------------------------
ATTENTION!  Your password for authentication realm:

   <https://svn.mozilla.org:443> Mozilla LDAP

can only be stored to disk unencrypted!  You are advised to configure
your system so that Subversion can store passwords encrypted, if
possible.  See the documentation for details.

You can avoid future appearances of this warning by setting the value
of the 'store-plaintext-passwords' option to either 'yes' or 'no' in
'/home/meteor/.subversion/servers'.
-----------------------------------------------------------------------
Store password unencrypted (yes/no)? yes
Sending        channel.lang
Transmitting file data .svn: E195023: Commit failed (details follow):
svn: E195023: Changing file '/home/meteor/workspace/mozilla.com/locales/zh-CN/firefox/channel.lang' is forbidden by the server
svn: E175013: Access to '/!svn/txr/141662-330c/projects/mozilla.com/trunk/locales/zh-CN/firefox/channel.lang' forbidden
svn: E175002: Additional errors:
svn: E175002: PUT of '/!svn/txr/141662-330c/projects/mozilla.com/trunk/locales/zh-CN/firefox/channel.lang': 403 Forbidden


Still the same error.
Flags: needinfo?(liuxingmatt)
Ah, now I think I see. You're trying to connect/commit with a password. I would strongly recommend using svn+ssh with an ssh key, I'm not clear that any other method will work.

See: https://wiki.mozilla.org/SVN

I don't see an ssh key associated with your account, you can add one via: https://login.mozilla.com/

It also appears that you have put a password into the bug. Please reset your password immediately if so via http://passwordreset.mozilla.org/
Flags: needinfo?(liuxingmatt)
(Reporter)

Comment 12

2 years ago
(In reply to Peter Radcliffe [:pir] from comment #11)
> Ah, now I think I see. You're trying to connect/commit with a password. I
> would strongly recommend using svn+ssh with an ssh key, I'm not clear that
> any other method will work.
> 
> See: https://wiki.mozilla.org/SVN
> 
> I don't see an ssh key associated with your account, you can add one via:
> https://login.mozilla.com/
> 
> It also appears that you have put a password into the bug. Please reset your
> password immediately if so via http://passwordreset.mozilla.org/

I have add the SSH key now.
But still see the same error
meteor@meteormatt:~/workspace/mozilla.com/locales/zh-CN/firefox$ svn commit -m "add </a> after 给我们提供反馈"
Sending        channel.lang
Transmitting file data .svn: E220004: Commit failed (details follow):
svn: E220004: Access denied
Flags: needinfo?(liuxingmatt)
I'm out of ideas, everything seems to be there.
:hwine, any thoughts?
Flags: needinfo?(hwine)
Pir: the process is documented at https://mana.mozilla.org/wiki/pages/viewpage.action?pageId=1081618#CreateSVN(HG&Git)Accounts-CreatingSVNLocalizerAccounts

Sounds like you still need to do the puppet work.

Note: SSH key is not needed for localizers.
Flags: needinfo?(hwine)

Updated

2 years ago
Group: mozilla-employee-confidential
The user is already in the @localizers svn group, though this account was never specifically listed as a localiser account, just asked for access to an svn path.
(Reporter)

Comment 16

2 years ago
(In reply to Peter Radcliffe [:pir] from comment #15)
> The user is already in the @localizers svn group, though this account was
> never specifically listed as a localiser account, just asked for access to
> an svn path.

I need SVN checkin now.
Sorry about the unclear expression.
(Assignee)

Updated

2 years ago
Blocks: 1168936

Comment 17

2 years ago
Liu - are you able to SVN commit?
(Reporter)

Comment 18

2 years ago
(In reply to Vinh Hua [:vinh] from comment #17)
> Liu - are you able to SVN commit?

It is OK now.

meteor@meteormatt:~/workspace/mozilla.com/locales/zh-CN/firefox$ svn commit -m "add </a> after 给我们提供反馈" --username liuxingmatt@gmail.com --password
Sending        channel.lang
Transmitting file data .
Committed revision 141869.

Thank you very much.

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.