onmouseover/onmouseout not working properly in <TABLE>

VERIFIED WORKSFORME

Status

()

Core
DOM: Events
VERIFIED WORKSFORME
17 years ago
16 years ago

People

(Reporter: pajor, Assigned: joki (gone))

Tracking

Trunk
mozilla1.2alpha
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.7) Gecko/20011221
BuildID:    2001122108

Table elements don't seem to respond to onmouseout events.  Example at
http://www.gnuyen.org/~pajor/test.html
Maybe related to bug 103055 or 90194.

Reproducible: Always
Steps to Reproduce:
1. Create a Table element
2. Assign something to its onmouseout event
3. move your mouse over and then out to see if it works

Actual Results:  Javascript isn't called

Expected Results:  Call the javascript

Comment 1

17 years ago
Confirming that there is a problem with onmouseover and onmouseout(Win98,
2001122103). But, in your testcase, there is an excessive onmouseover/onmouseout
events trapping in the the second <TD>. Attaching the corrected test case here.
The real issue is the following:
1) the above mouse events are triggered only for the first column. If <TABLE>
contains only onmouseout, again mousing over 2nd column doesn't trigger the event.
2) on the first column, onmouseover works (turns cell's background color to
black) but onmouseout doesn't (cannot change color to green).

Changing summary from "In a Table  onmouseover works but onmouseout doesn't" to
"Onmouseover/onmouseout are not working properly in <TABLE>".
Additional note: if try those events in both TDs, they work as expected (see
second attachment).
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: In a Table onmouseover works but onmouseout doesn't.

Comment 2

17 years ago
Created attachment 62642 [details]
testcase showing the issue

Comment 3

17 years ago
Created attachment 62643 [details]
this works as expected

Updated

17 years ago
OS: Linux → All
Summary: onmouseover/onmouseout not working properly in <TABLE>
(Reporter)

Comment 4

17 years ago
<QA ignore>
Well my test example was designed to show the desired behavior as well as the
broken behavior, mainly to show that the onmouseout code was sane and goodly. 
I'm sorry for not being familiar with how you guys do things.
</QA ignore>

Comment 5

17 years ago
Didn't blame you, your report was fine. I just clarified the testcase a bit.

Comment 6

17 years ago
On http://www.vodafone.pt/pt/oferta/servicos/index.asp there's a table with some
images (on a columns, some text next to each, can't miss it). Moving the mouse
over them is supposed to make a <div> visible but it doesn't work. Mozilla (upto
0.9.7 atleast) just looks at <a href="javascript:"> and pops up the JS console.  

Is this the same problem ?

Comment 7

17 years ago
On http://www.vodafone.pt/pt/oferta/servicos/index.asp there's a table with some
images (on a columns, some text next to each, can't miss it). Moving the mouse
over them is supposed to make a <div> visible but it doesn't work. Mozilla (upto
0.9.7 atleast) just looks at <a href="javascript:"> and pops up the JS console.  

Is this the same problem ?

Comment 8

17 years ago
I have too seen this boog in the wild at
http://members.home.net/vision/main_frame.htm (on the top frame). Was going to
induct but since it's already here I'll just add this one to the list ;)

Cheers
Shawn

Updated

16 years ago
Target Milestone: --- → mozilla1.2

Comment 9

16 years ago
Created attachment 73183 [details]
Another testcase

I saw a mozilla bug on the research index site. For example look at this page:

http://citeseer.nj.nec.com/471570.html

And move the mouse over the line starting with 'Cached' at the top right. 

Result: 
-The text jumps to the right
-Some other text at the left also jumps to the right
-the url bar extends fully to the right, removing the search and print icons.

The testcase is a simplified version of the page. Note that the text 'some
text' also moves.

Comment 10

16 years ago
Using latest Linux build, the only bug is the first testcase doesn't do onmouseout.

Comment 11

16 years ago
This works for me on build 2002-05-13-08-trunk win 98
and build 2002-05-13-10-trunk on Linux 
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Comment 12

16 years ago
verifying that onmouseover and onmouseout work as expected now, (2002051908, Win2K).
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.