Need i18n support for filter/search backend

VERIFIED FIXED in M17

Status

MailNews Core
Internationalization
P3
normal
VERIFIED FIXED
18 years ago
9 years ago

People

(Reporter: nhottanscp, Assigned: Alec Flett)

Tracking

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta2+]Exception Feature [FEATURE])

(Reporter)

Description

18 years ago
The current back end is not i18n ready (e.g. old converter should be replaced
by the new one etc..).
Please put appropriate target mile stone, thanks.

Updated

18 years ago
Assignee: bienvenu → mscott
Target Milestone: M15
(Reporter)

Comment 1

18 years ago
I summarized i18n requirement in a document below.
http://www.mozilla.org/projects/intl/mail-news-i18n-spec.html#Local mail search 
i18n

Header search 

MIME decode and charset conversion for headers - 
search term is now unicode (used to be a folder charset), 
we should compare it against MIME decoded and unicode converted header strings. 

Body search 

4.x implementation:  
    converts body text to win_csid. - no need to support this in mozilla 
proposal for mozilla: 
    convert body text to unicode. 
    QP decode for body (plain and HTML) 
    Entity (CER) and NCR decode for HTML body 

Comment 2

18 years ago
triaging since M15 is tonight. Not an M15 stoppper.
Target Milestone: M15 → M16

Updated

18 years ago
Blocks: 14744
(Reporter)

Comment 3

17 years ago
Putting beta2 for i18n beta2 criteria items. Contact bobj for question.
Keywords: beta2
(Reporter)

Updated

17 years ago
Blocks: 35851

Updated

17 years ago
Keywords: nsbeta2

Comment 4

17 years ago
Putting on [nsbeta2+] radar.  Need to fix by 5/16...+ for i18n search at least 
as good as 4.x.
Keywords: beta2
Whiteboard: [nsbeta2+][5/16][FEATURE]

Comment 5

17 years ago
Mass moving M16 to M17 - look for nsbeta2 before anything else.
Target Milestone: M16 → M17

Comment 6

17 years ago
Removing [nsbeta2+][5/16]... is this mandatory for I18n RTM?
Whiteboard: [nsbeta2+][5/16][FEATURE] → [NEED INFO][FEATURE]
(Reporter)

Comment 7

17 years ago
yes, the user should be able to search messages, this is supported in 4.x.

Comment 8

17 years ago
Yes, searching and filtering of non-ASCII is mandatory.
This would be a major regression from previous releases.
Keywords: 4xp

Comment 9

17 years ago
On exception list for PR2, removing 5/16...giving [nsbeta2+]Exception Feature 
status.
Whiteboard: [NEED INFO][FEATURE] → [nsbeta2+]Exception Feature [FEATURE]
(Assignee)

Comment 10

17 years ago
I just landed a TON of internationalization work to search and filters
yesterday, so I'm going to take this bug and mark it fixed... I think further
i18n issues should be taken up on exception by exception basis.



Assignee: mscott → alecf
(Assignee)

Comment 11

17 years ago
adding mscott back to the CC and marking fixed.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 12

17 years ago
Alec, can I proceed on the assumption that specs mentioned in
nhotta@netscape.com 2000-03-24 10:09 commet have been 
implemented?

Also what is working at FE?

1. Search/Find in msgs
2. IMAP search
3. Local Folder search
4. Filtering incoming msgs
(Assignee)

Comment 13

17 years ago
yes, I think everything nhotta describes is implemented, or at least I've seen 
the code to do everything that is described.

The FE should at least be able to spit things to the screen in the next day or 
so.
(Assignee)

Comment 14

17 years ago
oh, and to comment on your list:
1) done using the same technique as the browser. But this has nothing to do with 
search/filters, so let's not include that in this bug.`
2) I don't think this is completely implemented
3) bienvenu says this is now working
4) filters should now be i18n friendly. There may be an issue with migrated 
filters from 4.x though, because I'm assuming filter values are encoded in utf8, 
and I think the 4.x filters were in the system charset. I have a seperate bug on 
that though.
(Assignee)

Comment 15

17 years ago
*** Bug 5933 has been marked as a duplicate of this bug. ***

Comment 16

17 years ago
** Checked with 8/2/2000 Win32 M17 build **

OK. I'm going to mark this verified as fixed
though I believe that there might be several things not 
working with search or filter i18n-wise. 
We have filed some bugs and we should file others as needed.

Basic IMAP search is working -- header and body.
Basic Local Folder search seems to be working for headers only.
Basif filter -- this depends on the day. Today it does even work
   for Enlgish. I trust that someone has filed a bug for this.

Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.