Closed Bug 1166004 Opened 5 years ago Closed 5 years ago

[marker] Add `isPlatform` field for markers that aren't actionable/interesting for web developers

Categories

(DevTools :: Performance Tools (Profiler/Timeline), defect)

41 Branch
defect
Not set

Tracking

(firefox41 affected)

RESOLVED DUPLICATE of bug 1166005
Tracking Status
firefox41 --- affected

People

(Reporter: jsantell, Assigned: jsantell)

References

(Blocks 1 open bug)

Details

We have some instances where we have JS markers from the platform that aren't actionable or make any sense to a web developer, like "nsGlobalWindow report new global" when a debugger instance is wired up. We should hide these behind a `isPlatform` field on ProfileTimelineMarker, and still display them, but obfuscate the name unless Show Platform Data is on (similar to what we do for the call tree, in showing how it impacted performance, but hide names behind general categories)
I think this should be done at the devtools config level, rather than the platform level (it isn't clear to me, which you are proposing).
I think I'd prefer it on the platform level (as part of ProfileTimelineMarker itself), in the case where the "reasons" change on the platform
Assignee: nobody → jsantell
(In reply to Jordan Santell [:jsantell] [@jsantell] from comment #2)
> I think I'd prefer it on the platform level (as part of
> ProfileTimelineMarker itself), in the case where the "reasons" change on the
> platform

Whether or not the marker is shown is a UI concern, not really a platform concern IMO.
That is true -- I just worry about getting out of sync with marker name changes, but realistically that shouldn't happen often.
Handling this in bug 1166005 on the client
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1166005
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.