Last Comment Bug 116601 - [RFE] Share Mail Between Dual Boot OSes
: [RFE] Share Mail Between Dual Boot OSes
Status: VERIFIED DUPLICATE of bug 12911
:
Product: MailNews Core
Classification: Components
Component: Backend (show other bugs)
: Trunk
: x86 All
: -- enhancement (vote)
: ---
Assigned To: David :Bienvenu
: esther
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2001-12-22 13:51 PST by Daniel Jensen
Modified: 2008-07-31 01:21 PDT (History)
0 users
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Daniel Jensen 2001-12-22 13:51:56 PST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2.1) Gecko/20010901

Most things in Mozilla are sharable between different operating systems on a
dual boot system- I can comfortably use my preferences, bookmarks, etc. on both
windows and linux by mounting my windows drive and setting the folder on Linux
to be the folder I use on Windows- but several things in Mail don't work at all,
and this is due to the manner in which the path is demonstrated in the prefs
files. Windows stores the absolute location of the prefs, e.g.
d:\\users\mozilla\me, which linux can't understand. If the browser expected
relative path information from the prefs file (.//, in my case) and the prefs
file was written to in this way, it would work (unless there's a problem with
..'ing from one drive to another in Windows, which I'm not sure about). This
would be the ultimate in cross-platform compatibility.

Reproducible: Always
Steps to Reproduce:
1. Make an account with mailnews on windows.
2. Boot into Linux and set Mozilla's user folder to the folder on the mounted
vfat drive where your Windows prefs are set.
3.Start moz on Linux and watch everything come up just as it was in Windows
except for your mail.

Actual Results:  Mail folder shows accounts and details but can't reach storage
paths.

Expected Results:  Mail folder reads storage paths, you can manipulate your mail
all you want on either platform and have it carry over fully.
Comment 1 Matthias Versen [:Matti] 2001-12-22 14:32:27 PST

*** This bug has been marked as a duplicate of 12911 ***
Comment 2 David :Bienvenu 2001-12-22 14:35:36 PST
nothing to do with the mail database, which is what we store the summary of mail
header info in. You're describing some other problem. You can share data between
linux and windows but you can't share a profile, which is what you want to do,
if I understand you correctly. Also, we store our paths to mail files as URI's,
which are platform independent, e.g., user_pref("mail.identity.id2.fcc_folder",
"imap://user@server/Sent"); Perhaps you're saying that the profile mgr stores
absolute file system paths, but then why would you say that's a mail bug? What
file are you saying is storing native paths?
Comment 3 David :Bienvenu 2001-12-22 14:36:18 PST
thanks, right, I thought it was a profile mgr bug.

Note You need to log in before you can comment on or make changes to this bug.