Mozilla 0.96 and 0.97 crash on opening mail

RESOLVED WORKSFORME

Status

MailNews Core
Backend
--
critical
RESOLVED WORKSFORME
16 years ago
9 years ago

People

(Reporter: Michael Eibl, Assigned: Scott MacGregor)

Tracking

({crash})

Trunk
PowerPC
Mac OS X
crash

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
When clicking on certain mails in upper right window of the standard
Mail&Newsgroups interface Mozilla crashes instantaneously. All Mozilla task
windows disappear. This is absolutely reproducible. The same mails are perfectly
readable with the Classic Mac versions of Mozilla.

I would like to forward such a mail to someone to fix this bug.

Regards,
Michael
(Reporter)

Comment 1

16 years ago
Created attachment 62640 [details]
Source Code of an offending mail

This mail makes Mozilla crash.

Comment 2

16 years ago
This mail causes this crash:

From - Mon Apr  1 10:14:07 2002
X-UIDL: B1FAA6E202528A4A
X-Mozilla-Status: 0001
X-Mozilla-Status2: 00000000
Return-path: <A_La_Zing@meals.alazing.com>
Received: from mail.freeservers.com ([208.185.127.160]) by pop1 (v1.98)
    with ESMTP id (B1FAA6E202528A4A) for <smoore@mooreweb.com>; Mon,
    1 Apr 2002 11:12:28 -0700
Received: from uuout13smtp3.uu.flonetwork.com
    (uuout13smtp3.uu.flonetwork.com [205.150.6.103]) by mail.freeservers.com
    (Postfix) with ESMTP id 1916E42827 for <smoore@mooreweb.com>;
    Mon,  1 Apr 2002 11:11:32 -0700 (MST)
Received: from uucore10pumper2 (uuout13relay1.uu.flonetwork.com
    [172.20.73.10]) by uuout13smtp3.uu.flonetwork.com (Postfix) with SMTP id
    D138B82F2 for <smoore@mooreweb.com>; Mon,  1 Apr 2002 13:10:04 -0500 (EST)
Message-Id: <Kilauea55360-24639-22004049-1@flonetwork.com>
From: A La Zing <A_La_Zing@meals.alazing.com>
To: smoore@mooreweb.com
Subject: Buy One, Get One 50% off!
MIME-Version: 1.0
Content-Type: text/html; charset="us-ascii"
Content-Transfer-Encoding: 7bit
Date: Mon,  1 Apr 2002 13:10:04 -0500 (EST)

<html><body>
<table border="0" cellpadding="1" cellspacing="0" bgcolor="#5B195A"
align="center" width="550"><tr>
<td><a
href="http://meals.alazing.com/cgi-bin10/flo?y=hPWo0Bp1OJ0Gyn0f7p0Au"><img
src="http://a725.g.akamai.net/7/725/1095/0001/www.alazing.com/gifs/email/zemail_bogo50_01.gif"
width="548" height="205" border="0"></a><br>
<table border="0" cellpadding="0" cellspacing="0" bgcolor="white" width="548"><tr>
<td width="22" rowspan="2"><img
src="http://a725.g.akamai.net/7/725/1095/0001/www.alazing.com/gifs/fill.gif"
width="22" height="1"></td>
<td width="504"><img
src="http://a725.g.akamai.net/7/725/1095/0001/www.alazing.com/gifs/fill.gif"
width="1" height="8"><br>
<span style="font-family:arial; font-size:12px;"><b><i>Buy any of these A La
Zing complete meals and get the second complete meal at half price!</i></b>
That's right... now is the perfect time to stock-up on all your family
favorites... buy two meals at regular price, get 2 at 50% off, buy 3 at regular
price, get 3 at 50% off! Right now you can save BIG!<br>
<img
src="http://a725.g.akamai.net/7/725/1095/0001/www.alazing.com/gifs/fill.gif"
width="1" height="8"></span></td>
<td width="22" rowspan="2"><img
src="http://a725.g.akamai.net/7/725/1095/0001/www.alazing.com/gifs/fill.gif"
width="22" height="1"></td></tr>
<tr><td><img
src="http://a725.g.akamai.net/7/725/1095/0001/www.alazing.com/gifs/email/zemail_bogo50_02.gif"
width="504" height="23"><br>
<img src="/gifs/fill.gif" width="1" height="10"></td></tr></table>
<table border="0" cellpadding="0" cellspacing="0" bgcolor="white" width="548"><tr>
<td width="114" align="right" valign="bottom" rowspan="2"><img
src="http://a725.g.akamai.net/7/725/1095/0001/www.alazing.com/gifs/email/zemail_bogo50_03.gif"
width="92" height="75" border="0"></td>
<td colspan="2" valign="bottom"><a
href="http://meals.alazing.com/cgi-bin10/flo?y=hPWo0Bp1OJ0Gyn0f7p0Au"
style="color:#5B195A;"><span style="font-family:arial;
font-size:22px;"><b><i>Filet Mignon Feast</i></b></span></a><span
style="font-family:arial; font-size:12px; color:#5B195A;"><b><i> - Serves
Two</i></b></span></td></tr>
<tr><td width="16" valign="bottom"><img
src="http://a725.g.akamai.net/7/725/1095/0001/www.alazing.com/gifs/email/zemail_bogo50_04.gif"
width="16" height="40" border="0"></td>
<td width="418" valign="top"><span style="font-family:arial; font-size:15px;
color:#5FABE4;"><b><i>BUY ONE FOR $29.99, GET ANOTHER AT "50%
OFF"</i></b></span><br>
<span style="font-family:arial; font-size:12px; color:#5B195A;"><i>(Includes:
Twice Baked Potatoes and Roasted Vegetable Medley.)</i></span></td></tr>
<tr><td align="right" colspan="3"><img
src="http://a725.g.akamai.net/7/725/1095/0001/www.alazing.com/gifs/email/zbuyone_fade.gif"
width="460" height="1"></td></tr>
<tr><td align="right" valign="bottom" rowspan="2"><img
src="http://a725.g.akamai.net/7/725/1095/0001/www.alazing.com/gifs/email/zemail_bogo50_03.gif"
width="92" height="75" border="0"></td>
<td colspan="2" valign="bottom"><a
href="http://meals.alazing.com/cgi-bin10/flo?y=hPWo0Bp1OJ0Gyn0f7p0Au"
style="color:#5B195A;"><span style="font-family:arial;
font-size:22px;"><b><i>Broccoli/Cheese Chicken EntrĂˆe</i></b></span></a><span
style="font-family:arial; font-size:12px; color:#5B195A;"><b><i> - Serves
Two</i></b></span></td></tr>
<tr><td valign="bottom"><img
src="http://a725.g.akamai.net/7/725/1095/0001/www.alazing.com/gifs/email/zemail_bogo50_04.gif"
width="16" height="40" border="0"></td>
<td valign="top"><span style="font-family:arial; font-size:15px;
color:#5FABE4;"><b><i>BUY ONE FOR $19.99, GET ANOTHER AT "50%
OFF"</i></b></span><br>
<span style="font-family:arial; font-size:12px; color:#5B195A;"><i>(Includes:
Glazed Julienne Carrots and Herb Roasted Potato Wedges.)</i></span></td></tr>
<tr><td align="right" colspan="3"><img
src="http://a725.g.akamai.net/7/725/1095/0001/www.alazing.com/gifs/email/zbuyone_fade.gif"
width="460" height="1"></td></tr>
<tr><td align="right" valign="bottom" rowspan="2"><img
src="http://a725.g.akamai.net/7/725/1095/0001/www.alazing.com/gifs/email/zemail_bogo50_03.gif"
width="92" height="75" border="0"></td>
<td colspan="2" valign="bottom"><a
href="http://meals.alazing.com/cgi-bin10/flo?y=hPWo0Bp1OJ0Gyn0f7p0Au"
style="color:#5B195A;"><span style="font-family:arial;
font-size:22px;"><b><i>Tuna Steak Dinner</i></b></span></a><span
style="font-family:arial; font-size:12px; color:#5B195A;"><b><i> - Serves
Two</i></b></span></td></tr>
<tr><td valign="bottom"><img
src="http://a725.g.akamai.net/7/725/1095/0001/www.alazing.com/gifs/email/zemail_bogo50_04.gif"
width="16" height="40" border="0"></td>
<td valign="top"><span style="font-family:arial; font-size:15px;
color:#5FABE4;"><b><i>BUY ONE FOR $24.99, GET ANOTHER AT "50%
OFF"</i></b></span><br>
<span style="font-family:arial; font-size:12px; color:#5B195A;"><i>(Includes:
Rice Pilaf and Whole Green Beans.)</i></span></td></tr>
<tr><td align="right" colspan="3"><img
src="http://a725.g.akamai.net/7/725/1095/0001/www.alazing.com/gifs/email/zbuyone_fade.gif"
width="460" height="1"></td></tr>
<tr><td align="right" valign="bottom" rowspan="2"><img
src="http://a725.g.akamai.net/7/725/1095/0001/www.alazing.com/gifs/email/zemail_bogo50_03.gif"
width="92" height="75" border="0"></td>
<td colspan="2" valign="bottom"><a
href="http://meals.alazing.com/cgi-bin10/flo?y=hPWo0Bp1OJ0Gyn0f7p0Au"
style="color:#5B195A;"><span style="font-family:arial;
font-size:22px;"><b><i>Traditional Lasagna Dinner</i></b></span></a><span
style="font-family:arial; font-size:12px; color:#5B195A;"><b><i> - Serves
Two</i></b></span></td></tr>
<tr><td valign="bottom"><img
src="http://a725.g.akamai.net/7/725/1095/0001/www.alazing.com/gifs/email/zemail_bogo50_04.gif"
width="16" height="40" border="0"></td>
<td valign="top"><span style="font-family:arial; font-size:15px;
color:#5FABE4;"><b><i>BUY ONE FOR $14.99, GET ANOTHER AT "50%
OFF"</i></b></span><br>
<span style="font-family:arial; font-size:12px; color:#5B195A;"><i>(Includes:
Whole Green Beans and a Tiramisu Cake.)</i></span></td></tr>
<tr><td align="right" colspan="3"><img
src="http://a725.g.akamai.net/7/725/1095/0001/www.alazing.com/gifs/email/zbuyone_fade.gif"
width="460" height="1"></td></tr>
<tr><td align="center" colspan="3"><img
src="http://a725.g.akamai.net/7/725/1095/0001/www.alazing.com/gifs/fill.gif"
width="1" height="10"><br>
<span style="font-family:arial; font-size:12px;"><b><i>Offer expires promptly at
midnight April 10th, 2002!</i></b><br></span>
<img
src="http://a725.g.akamai.net/7/725/1095/0001/www.alazing.com/gifs/fill.gif"
width="1" height="10"></td></tr></table>
</td></tr></table>
<table border="0" cellpadding="0" cellspacing="0" align="center" width="550"><tr>
<td><span style="font-family:arial; font-size:12px;"><p><br>A La Zing, a brand
of Omaha Steaks, sends special information and offers every 5-10 days to
individuals who        have requested them.  You have received this message
because you are on <nobr>A La Zing's</nobr> mailing list.<br><br>If you feel you
have received this message in error or you wish to
be removed from this list, please go to <a
href="http://meals.alazing.com/cgi-bin10/flo?y=hPWo0Bp1OJ0Gyn0f630As&EmailAddr=smoore@mooreweb.com"
style="color:#000000">unsubscribe</a> and you will automatically be removed from
the list. Please allow 7 business days for completion of
removal.</SPAN></p></td></tr></table>
</body>
<IMG SRC="http://meals.alazing.com/cgi-bin10/flosensing?y=PWo0Bp1OJ0Gynk"></html>

I'm running OSX and using Mozilla .9.9+ (Gecko/20020326)

Comment 3

16 years ago
Michael, can you still reproduce this using RC1? If so, please attach a Crash
Report hereon.
Severity: major → critical
Keywords: crash

Comment 4

16 years ago
Resolving WorksForMe per Reporter.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.