Closed Bug 1166113 Opened 7 years ago Closed 3 years ago

Use data from the autocomplete result to fill the correct password

Categories

(Toolkit :: Password Manager, defect, P1)

Desktop
All
defect

Tracking

()

VERIFIED FIXED
mozilla69
Tracking Status
firefox68 --- wontfix
firefox69 + verified
firefox70 --- verified

People

(Reporter: tanvi, Assigned: MattN)

References

(Blocks 1 open bug)

Details

(Whiteboard: [passwords:tech-debt] [passwords:fill-ui] [passwords:generation] [skyline] )

Attachments

(1 file)

When the Password Manager finds more than one login, the way we fill username and passwords is a bit odd (see bug 1127567 comment 15).

First we search for logins to fill the username field.  Then we search for logins again to fill the password field (and make an additional request to the parent).  Instead, we should take the data returned from nsLoginManager.js:autoCompleteSearchAsync to populate the username, and also use it to populate the password field.
Blocks: 1159538
Flags: firefox-backlog+
Blocks: 1147563
Blocks: 1193404
Flags: qe-verify?
Priority: -- → P1
Whiteboard: [fxprivacy]
Priority: P1 → P2
Priority: P2 → P4
Flags: qe-verify? → qe-verify-
Priority: P4 → P2
Whiteboard: [fxprivacy]
No longer blocks: 1193404

The autocomplete results should be fetched and populated only in the parent process then upon filling, fillForm can be used. See also bug 1520280 for satchel.

See Also: → 1513003, 1520280
Whiteboard: [passwords:tech-debt]

[Tracking Requested - why for this release]: Needed for bug 589628 otherwise the wrong password will be filled if there are multiple autocomplete suggestions for the same username (e.g. on different subdomains).

For Firefox 69 I think we can just use the guid of the filled login at the time of "autocomplete-did-enter-text" to fill the correct password.

Flags: qe-verify-
Flags: qe-verify+
Flags: in-testsuite?
OS: Unspecified → All
Priority: P2 → P1
Hardware: Unspecified → Desktop
Whiteboard: [passwords:tech-debt] → [passwords:tech-debt] [passwords:fill-ui]
Summary: Use data from autoCompleteSearchAsync to fill username and password → Use data from the autocomplete result to fill the correct password
Blocks: 589628
Blocks: 1555209

I didn't do the full solution proposed in comment 1 so I filed bug 1555209 for that.

Assignee: nobody → MattN+bmo
Status: NEW → ASSIGNED
See Also: 1513003, 1520280
Pushed by mozilla@noorenberghe.ca:
https://hg.mozilla.org/integration/autoland/rev/9ac9f25a4339
Use the autocomplete result GUID to fill the correct password. r=sfoster
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla69

Hi Guys, Do you have any steps for this issue on how we can reproduce and confirm the Fix ?

Flags: needinfo?(MattN+bmo)
Regressions: 1556953

(In reply to Rares Doghi from comment #7)

Hi Guys, Do you have any steps for this issue on how we can reproduce and confirm the Fix ?

See

Needed for bug 589628 otherwise the wrong password will be filled if there are multiple autocomplete suggestions for the same username (e.g. on different subdomains).

Save two logins with the same username but different passwords on two different subdomains (you can use about:logins for this) then ensure the correct matching password is filled for both logins from the autocomplete popup. This only applies on Fx70+ since the two prefs at https://phabricator.services.mozilla.com/D26389#change-5D4xp5p5yudd need to be true.

Flags: needinfo?(MattN+bmo)
Whiteboard: [passwords:tech-debt] [passwords:fill-ui] → [passwords:tech-debt] [passwords:fill-ui] [passwords:generation] [skyline]

Thank you Matthew, This issue is Verified as Fixed in Firefox 70.0a1 (2019-07-10) on Windows, Ubuntu and Mac OSX

This issue is also verified as fixed in 69.0b4 with the 2 mentioned preferences from about config manually set to "True".

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.